Transmission or clutch problem - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-29-2008, 12:36 PM   #1
Jeeper
 
mechanicforme's Avatar
 
Join Date: Dec 2008
Location: Louisiana
Posts: 44
Transmission or clutch problem

hey guys lets see i bought an automatic 99 jeep wrangler in dallas and i live in Louisiana it made the trip home amazingly, its been about 8 months now since then and i have put alot of work into it keep in mind this is my first jeep. Ok so that being said just recently i got the gaskets replaced on my transmission because it was a little leaky but now i have a new problem it dosent happen all the time but it does happen when i have 3-4 people riding with me the rpms rev up and then back down again no grinding or bad noises but i am wondering if this is tranny slip or is it my clutch going bad again any help would be much a help.

mechanicforme is offline   Quote Quick Reply
Old 12-29-2008, 12:57 PM   #2
Jeeper
 
Join Date: Nov 2008
Location: Long Island
Posts: 59
Check the fluid. Should be to the full mark, not shy of it.
If thats not it could be the trans slipping.
Automatic trans will usually not make any grinding noise.

__________________
John is offline   Quote Quick Reply
Old 12-29-2008, 01:01 PM   #3
Jeeper
 
mechanicforme's Avatar
 
Join Date: Dec 2008
Location: Louisiana
Posts: 44
its about half way up the ok i will fill it up but if the tranny is slipping dosent it make a grinding noise?
mechanicforme is offline   Quote Quick Reply
Old 12-29-2008, 01:17 PM   #4
Jeeper
 
Join Date: Nov 2008
Location: Long Island
Posts: 59
Automatic trans will usually not make any grinding noise.
__________________
John is offline   Quote Quick Reply
Old 12-29-2008, 01:35 PM   #5
that's what she said

WF Supporting Member
 
jgano23's Avatar
 
Join Date: Oct 2008
Location: \m/-_-\m/
Posts: 16,482
Send a message via AIM to jgano23 Send a message via Yahoo to jgano23
i'd put money on the fact that it is NOT a clutch problem . you may need a transmission flush there could be crap in the tranny.
jgano23 is offline   Quote Quick Reply
Old 12-29-2008, 01:52 PM   #6
that's what she said

WF Supporting Member
 
jgano23's Avatar
 
Join Date: Oct 2008
Location: \m/-_-\m/
Posts: 16,482
Send a message via AIM to jgano23 Send a message via Yahoo to jgano23
you may need to get a metric adjustable wrench or left hand monkey wrench, some snew, and about 10' of fallopian tube. check back when you gather those supplies and i can give you the rest of the directions.
jgano23 is offline   Quote Quick Reply
Old 12-29-2008, 07:22 PM   #7
Jeeper
 
Join Date: Nov 2008
Location: Long Island
Posts: 59
I have also seen a flush give these auto trannys some more life
Good Luck
__________________
John is offline   Quote Quick Reply
Old 12-29-2008, 07:41 PM   #8
Jeeper
 
mechanicforme's Avatar
 
Join Date: Dec 2008
Location: Louisiana
Posts: 44
ok well when i got the gaskets changed i got the flush and new filters put in so that has already been done unless this tranny place screwed me over.
mechanicforme is offline   Quote Quick Reply
Old 12-29-2008, 07:49 PM   #9
that's what she said

WF Supporting Member
 
jgano23's Avatar
 
Join Date: Oct 2008
Location: \m/-_-\m/
Posts: 16,482
Send a message via AIM to jgano23 Send a message via Yahoo to jgano23
it is entirely possible, but not too likely. did they do an actual flush or did they just change the fluid?
jgano23 is offline   Quote Quick Reply
Old 12-29-2008, 09:31 PM   #10
Jeeper
 
mechanicforme's Avatar
 
Join Date: Dec 2008
Location: Louisiana
Posts: 44
yes thats what i asked for and its whats on the receipt .

mechanicforme is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
Problem with clutch? Paul.mea TJ Tech Forum 9 01-16-2009 07:25 PM
1990 need help transmission or clutch problem ?? sxmjeepdriver YJ Tech Forum 13 11-02-2008 11:01 AM
Clutch problem locorogue YJ Tech Forum 0 07-09-2008 09:06 PM
Clutch? Transmission? Some advice needed ryobi YJ Tech Forum 4 10-10-2007 09:33 AM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 04:44 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC