voltage regulator gauge - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-15-2005, 02:26 PM   #1
Newb
 
Join Date: Aug 2005
Location: Manchester, New Hampshire
Posts: 7
voltage regulator gauge

I have a 1989 Wrangler YJ and the voltage regulator guage does not work. Any ideas on where I should start to try to fix it. Thank you

Michael Ferrari is offline   Quote
Old 08-15-2005, 08:36 PM   #2
Jeeper
 
daddyjeep's Avatar
 
Join Date: Apr 2005
Location: Smethport, PA
Posts: 3,039
Wranglers have been know to have problems with corrosion in the guage cluster. It is really easy to pull the dash apart and inspect the connections. There is a thin plastic sheet with the copper wires running through it. Check the connections to the wiring harness and pull the connectors on the guage side too. I found the corrosion on the guage side on mine. A little corrosion is all it takes. I used sand paper to clean it up. Let us know if this helps.

__________________
87 YJ, 5.2/46RH/NP231, Custom 4 link/ Radius Arms, Ballistic Nitrogen Shocks, 35" Cooper STT
DaddyJeep build Thread:http://www.wranglerforum.com/f8/dadd...ld-122601.html
daddyjeep is offline   Quote
Old 08-16-2005, 07:11 AM   #3
Newb
 
Join Date: Aug 2005
Location: Manchester, New Hampshire
Posts: 7
Thanks daddyjeep. I will let you know how I made out
Michael Ferrari is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
throwing code, running poorly xtsniper0 TJ General Discussion Forum 16 03-08-2011 12:24 PM
more juice 95_YJ YJ Tech Forum 8 09-08-2009 12:52 PM
TPS Voltage memsimba TJ Tech Forum 5 12-26-2005 04:57 PM
A/C Almost Done but Voltage Drops skippytheclown YJ General Discussion Forum 3 08-10-2005 09:21 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 02:12 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC