What am I missing.... - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-24-2010, 05:13 PM   #1
Jeeper
 
95GreenYeti's Avatar
 
Join Date: Feb 2010
Posts: 15
What am I missing....

Starting to put my 4" lift on today and for some reason I can not get the sway bars off. Both bolts are out..what I am doing wrong? Thanks. Here is a pic to get an idea.
Attached Thumbnails
Click image for larger version

Name:	DSC_0058.jpg
Views:	26
Size:	177.8 KB
ID:	16181  

95GreenYeti is offline   Quote Quick Reply
Old 02-24-2010, 06:55 PM   #2
Jeeper
 
turdhurdler's Avatar
 
Join Date: Dec 2008
Location: Hemet, CA Hemet is Heaven...
Posts: 7,167
Send a message via AIM to turdhurdler
If you have the bolts on both sides of the frame that connect the sway bar out and still no go, then try some penetrating oil and a dead blow hammer. Personally, I still have my sway bar hooked up with my 4" lift. I did remove the from and rear track bars though to soften up the ride. If you remove the sway bar also, you may get a lot of body roll in turns.

Jeff

__________________
Mall crawlin' in 4 Lo.
turdhurdler is online now   Quote Quick Reply
Old 02-25-2010, 02:22 AM   #3
Newb
 
Join Date: Feb 2010
Posts: 8
you said "both" bolts are out, did you mean both bolts on the sway bar links (4 total), or just the bolts that connect the links to the sway bar (2 total). If you've still got the bottom bolts in the links down at the axle, it will probably be easier to remove if you pull those out too. After that, penetrating oil, and a big hammer. Personally, I'd pull the whole dang thing off of there and throw it over the hill. You don't really need it on the YJ, but I would recommend leaving the track bar in place. I pulled my rear track bar, front sway bar, and front track bar on mine, but ended up putting the front track back on, that was a bit too much sway for me, but you should be alright with just losing the sway bar.
whitefeather010 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Missing Steering columns?????? crtaylor YJ General Discussion Forum 0 11-07-2009 07:19 PM
Back up light switch woes, what am I missing? Covrace YJ General Discussion Forum 0 06-23-2009 11:57 AM
Unknown missing parts Hank TJ Tech Forum 22 06-03-2009 01:33 AM
Am I missing a fan? k7svv JK General Discussion Forum 4 04-02-2009 05:09 AM
Missing Dash Bolt - 99' TJ Rickster49426 TJ Tech Forum 1 03-17-2008 03:18 PM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 10:25 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC