1987 help wrangler 6cyl 4.2L. - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > CJ Jeep Forum > CJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-17-2012, 01:51 AM   #1
Newb
 
Smith4x4's Avatar
 
Join Date: Jul 2012
Posts: 3
1987 help wrangler 6cyl 4.2L.

I need help guys. My jeep I just bought keeps stalling at every stop light and has a real rough idle. I took all the guts out the cadillactic converter. I put an aluminum valve cover on. Plastic one was leaking... How do I get it to run??? Any info will help... I looked at the T.B.I. conversion kit. Fuel injection... too much money right now.

Smith4x4 is offline   Quote Quick Reply
Old 07-17-2012, 08:08 AM   #2
Jeeper
 
Join Date: Apr 2012
Location: OKC, Oklahoma
Posts: 74
You might need to time it again, you could clean the carb, try a higher grade fuel and if that stops the roughness, then clean out your gas tank. Check spark plugs, distributer wires, etc. That's all I can say without knowing more

JeepNub is offline   Quote Quick Reply
Old 07-17-2012, 09:32 AM   #3
Jeeper
 
GrimmJeeper's Avatar
 
Join Date: Jul 2012
Location: Brentwood
Posts: 43
I am not shure about yours but my 87 wrangler 2.5 tbi gives me fits now and then, try MAP,O2,TPS,CPS, full tune up,,, cap,rotor plugs wires, fuel filter carb clean, Start with the basics, Comp,fuel,spark, without those 3 things nothing will run.
GrimmJeeper is offline   Quote Quick Reply
Old 07-17-2012, 10:31 AM   #4
Jeeper
 
CJ-John's Avatar
 
Join Date: Jun 2009
Location: Back in Upstate New york
Posts: 311
Did this all start when you changed the valve cover? If so one or more vacuum lines make be loose and or leaking. just a thought
__________________
79 CJ-7 304 4 speed all stock
07 Dodge Nitro
03 Harley FXD Superglide
12 Chevy Malibu
Back in the finger lakes area of upstate NY
CJ-John is offline   Quote Quick Reply
Old 07-23-2012, 02:19 PM   #5
Newb
 
Smith4x4's Avatar
 
Join Date: Jul 2012
Posts: 3
Na. It's was running rough before the valve cover job... all the vaccume lines are new. Somethings wrong with the carb. I think not sure tho. Thx. Guys for your info... I found a jeep shop in Pinetop. Az. So I'm gunna let the shop get it going. I'm sick of messing with it.
Smith4x4 is offline   Quote Quick Reply
Old 07-23-2012, 02:33 PM   #6
IITYWTMWYBMAB

WF Supporting Member
::WF Administrator::
 
4Jeepn's Avatar
 
Join Date: Apr 2005
Location: Florence, KY
Posts: 9,449
Images: 5
sounds like carb or vacume line problems.

__________________
79.96.85.00.01.97.00.97.93.97.95.94
CJ.XJ.CJ. TJ. TJ.ZJ. TJ.TJ. ZJ.ZJ.YJ. XJ
4Jeepn is online now   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 05:55 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC