1997 Brake and Idle Problem - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > CJ Jeep Forum > CJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-21-2008, 04:14 PM   #1
Newb
 
Join Date: Dec 2008
Posts: 1
1997 Brake and Idle Problem

I apologize if this is in the wrong location -

I have a 97 Wrangler 4 cyl

Earlier today I drove not even a quarter mile with the E-Brake engaged
I noticed that all of a sudden the car was idling around 2k - 2.3 k
and not just idling it was like the car was driving itself and also the brakes were near impossible to press.
So i pullsed over and added some brake fluid - it was def. low. But this didn't correct the problem.

I googled around because I didn't want to just make a post without researching first and read that it was probably a vacuum hose from the Intake Mani to the Brake Booster - I searched all throughout trying to locate a loose hose some where and I was unable to find any loose vacuum hoses - this is not to say that there isn't one - I just could not find it. Any help on this problem would be greatly appreciated!!!

Again sorry if this is in the wrong location and hopefully an admin can move me if it is.

norml is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
Runing rough, idle rough, cylinder #4 misfire spdrcrpete TJ General Discussion Forum 13 06-02-2008 01:32 PM



» Featured Product

All times are GMT -5. The time now is 05:41 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC