'76 CJ-7 4.2 won't start - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > CJ Jeep Forum > CJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-29-2012, 07:58 PM   #1
Jeeper
 
Join Date: Aug 2009
Location: Middle of Oklahoma
Posts: 31
'76 CJ-7 4.2 won't start

Working on my son's CJ and having no success getting it started. Seems to be getting gas and priming it has had no effect. Still has the original type ignition system and I've done all of the checks for continuity and resistance that are discussed in the tech manual.
My opinion is that the ECU is bad. I checked for continuity to ground for the ECU and all is well there. I don't have a pulse simulator to test the ECU with and I'm wondering if there is any other way to test an ECU. Do parts stores generally have testing equipment or since parts stores won't usually accept returns on electrical equipment am I left with just replacing the unit and hoping that was the problem.

GeePers is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 07:44 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC