'79 CJ7 problem - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > CJ Jeep Forum > CJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-28-2010, 10:39 PM   #1
Jeeper
 
bergy's Avatar
 
Join Date: Dec 2009
Location: Wisconsin
Posts: 1,116
'79 CJ7 problem

So my dad has a '79 CJ7 that he got about 9 months ago... he finally got some time to start working on it and he noticed that when accelerating the Jeep tends to pull to the right and when he lets off the gas it straightens back out ... it doesnt really matter what speed he is going just went he gets on the gas it pulls to the right and stops when he lets off... its a 6cyl engine, 3 speed manual trans, it has a 4in lift or so and he is running 33s... so i told him i would post something and see what people think it might be... thanks for any help

bergy is offline   Quote Quick Reply
Old 04-09-2010, 08:05 PM   #2
Jeeper
 
scrambler1's Avatar
 
Join Date: Jan 2008
Location: vermont
Posts: 486
I would check your centering pins on the front end.
__________________
94' wrangler 4 cyl. 5 speed D30/8.8 ARB
82' scrambler 350 TBI/700r4 D30/Currie 9"
07' JK sahara
Whats the deal with the facebook crap?? ->->->->
Grown men should NOT be on Facebook.
scrambler1 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 01:05 PM
05 tj rattle problem fixed. JeepGuyLJ TJ General Discussion Forum 2 05-25-2011 02:00 PM
'97 Wrangler Cold Idle / Load Flooding Problem brad07x TJ Tech Forum 1 12-19-2009 12:10 AM
different transmission problem greasem0nkey86 YJ Tech Forum 5 03-26-2007 04:31 PM
TJ Error codes khenderson TJ Tech Forum 3 08-19-2005 01:36 AM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 09:21 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC