Electrical gurus? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > CJ Jeep Forum > CJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-20-2012, 10:45 AM   #1
Jeeper
 
CJ-John's Avatar
 
Join Date: Jun 2009
Location: Back in Upstate New york
Posts: 318
Electrical gurus?

I'm having trouble with getting all my rear lights working properly. tail lights both work, brake lights both work, 4 way flashers and brake lights work but my right turn signal won't flash. now the turn signal uses the same circuit as the brake and 4 ways right? Also the indicator light in the speedo flashes for the right turn when I turn it on but the rear light does not. Now I do know that the switch for the right turn does not latch on (I have to hold it up) Any ideas? I do have another column that the switch latches on but I'm not sure it's a direct swap as I took it out of a 84 and mine is a 79 Thanks in advance. John

__________________
79 CJ-7 304 4 speed all stock
07 Dodge Nitro
12 Chevy Malibu
Back in the finger lakes area of upstate NY
CJ-John is offline   Quote Quick Reply
Old 07-20-2012, 10:52 AM   #2
Sponsoring Vendor
 
Ibuildembig's Avatar
 
Join Date: Aug 2010
Location: Fruitland, Missouri
Posts: 8,386
Id check the bulb first and maybe swap it with the left one if it works correctly. Or you can test it with a meter and see if it flashes at the contact points on the light itself, but you will need someone to hold the lever up for you.

Ibuildembig is online now   Quote Quick Reply
Old 07-20-2012, 03:14 PM   #3
Jeeper
 
CJ-John's Avatar
 
Join Date: Jun 2009
Location: Back in Upstate New york
Posts: 318
Quote:
Originally Posted by Ibuildembig View Post
Id check the bulb first and maybe swap it with the left one if it works correctly. Or you can test it with a meter and see if it flashes at the contact points on the light itself, but you will need someone to hold the lever up for you.
Yeah, I'll pull the bulb again but it works on both filaments for parking lights and 4 way flashers so? I'll give it a try. I've cleaned the ground once but I may do it again. Even thought about running a direct battery ground just hanging a wire down the outside for a test.
__________________
79 CJ-7 304 4 speed all stock
07 Dodge Nitro
12 Chevy Malibu
Back in the finger lakes area of upstate NY
CJ-John is offline   Quote Quick Reply
Old 07-23-2012, 03:14 PM   #4
Jeeper
 
CJ-John's Avatar
 
Join Date: Jun 2009
Location: Back in Upstate New york
Posts: 318
I've changed the flasher and the bulb now still the same. i guess I'll have to look at changing the switch, but the indicator in the speedo flashes. John
__________________
79 CJ-7 304 4 speed all stock
07 Dodge Nitro
12 Chevy Malibu
Back in the finger lakes area of upstate NY
CJ-John is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 05:18 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC