93 hard start - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Build Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-18-2013, 07:19 PM   #1
Newb
 
93WrAnGlEr93's Avatar
 
Join Date: Aug 2012
Location: Wantage, NJ
Posts: 13
93 hard start

Hello everybody. I went out to start my jeep today and it took awhile to start and i noticed the check engine light was on. So i pulled the codes and every time i go to read them its seems to change so i took a video and was wondering if anybody could help me figure them out. And figure out what is causing the hard start.

93WrAnGlEr93 is offline   Quote Quick Reply
Old 04-18-2013, 09:12 PM   #2
Jeeper
 
0III0forlife's Avatar
 
Join Date: Mar 2012
Location: Ridgway, Pa.
Posts: 2,961
The codes that i got from watching your video are: 12,33,24,21,15,55

12- system check. You will get this one everytime.
33- AC clutch. You will get this one everytime as well, unless you have AC.
24- TPS sensor. Part of your problem with the hard start. Throttle Position Sensor
21- O2 sensor. Another part of your problem.
15- Distance sensor. Thats the sensor for the speedo, Not sure why you are getting that code, I get it on mine cause i have a cable speedo, but yours should be electronic since its a 93.
55- Equals end of test.

So, replace the TPS and the O2 sensors, and your hard start problems should go away.

Atleast thats what my troubleshooting manual says that is what your OBDI is trying to tell you.

0III0forlife is offline   Quote Quick Reply
Old 04-19-2013, 07:33 PM   #3
Newb
 
93WrAnGlEr93's Avatar
 
Join Date: Aug 2012
Location: Wantage, NJ
Posts: 13
Thanks for the help. I figured out that the hard start was due to a bad distributor and rotor. replaced those and it starts perfect. but know it is hesitant while driving, could that be due to a bad tps sensor.
93WrAnGlEr93 is offline   Quote Quick Reply
Old 04-20-2013, 12:31 AM   #4
Jeeper
 
Tattoo Tony's Avatar
 
Join Date: Apr 2012
Location: Pine Barrens
Posts: 64
Could be both, TPS and O2.
Tattoo Tony is offline   Quote Quick Reply
Old 04-23-2013, 07:56 PM   #5
Newb
 
93WrAnGlEr93's Avatar
 
Join Date: Aug 2012
Location: Wantage, NJ
Posts: 13
got a new tps and put that on and it is still hesitating while driving. anybody got any opinions on what could cause the problem.
93WrAnGlEr93 is offline   Quote Quick Reply
Old 04-30-2013, 07:33 PM   #6
Newb
 
93WrAnGlEr93's Avatar
 
Join Date: Aug 2012
Location: Wantage, NJ
Posts: 13
Okay so im still having the problem. i have changed the tps, iac, and distributor. and it still seems to hesitate while driving. it seems to happen often when the jeep is still cold. what else could cause this? oh and im putting in a new fuel filter tomorrow i will let you know how that goes.

93WrAnGlEr93 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 02:47 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC