Need some picture help - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Pics Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-27-2014, 07:16 PM   #1
Jeeper
 
mijeeper80's Avatar
 
Join Date: Mar 2014
Posts: 563
Hey guys I am hoping someone is willing to snap a few pics of their body mounts in good condition, I have a 3 inch body lift and it's reeking havoc on the body as you can tell by the pics. I need to know what good mounts to body on a yj look like so I can fix the problem properly. If anyone can snap some of the same pics I took of mine I would be greatly appreciative. I know I need to weld some new plates on but I need to know what it was supposed to look like originally because everything is so bent and abused now.

I can more/better pics if it would help

mijeeper80 is offline   Quote Quick Reply
Old 06-27-2014, 08:15 PM   #2
Jeeper
 
GreggM's Avatar
 
Join Date: Apr 2014
Location: Michigan
Posts: 255
Looks like you have some fun ahead of you. Are you looking for pictures from underneath? If do here are a couple. Let me know what else you need. Both mounts are drivers side
Attached Thumbnails
Click image for larger version

Name:	image-4002518884.jpg
Views:	48
Size:	172.5 KB
ID:	1246034   Click image for larger version

Name:	image-910635686.jpg
Views:	47
Size:	193.4 KB
ID:	1246042  


GreggM is offline   Quote Quick Reply
Old 06-27-2014, 08:36 PM   #3
Jeeper
 
mijeeper80's Avatar
 
Join Date: Mar 2014
Posts: 563
Yes that does help, I thought that was supposed to be flat. My main problem is this one Is thT plate supposed to be flat and is that all that supports that mount? Seems thin and flimsy even if it was right. Also back left rear is that all supposed to be sitting even with the straight line of the tub?


It looks flat in the pic but it's pushed way up and is just flimsy as hell
Attached Thumbnails
Click image for larger version

Name:	image-2264680949.jpg
Views:	47
Size:	132.1 KB
ID:	1246138   Click image for larger version

Name:	image-971357384.jpg
Views:	44
Size:	130.5 KB
ID:	1246154  

mijeeper80 is offline   Quote Quick Reply
Old 06-27-2014, 09:47 PM   #4
Jeeper
 
GreggM's Avatar
 
Join Date: Apr 2014
Location: Michigan
Posts: 255
I'll try and get a shot of my back mounts in the morning. I'll be under it putting in a tail pipe
GreggM is offline   Quote Quick Reply
Old 06-27-2014, 10:37 PM   #5
Jeeper
 
mijeeper80's Avatar
 
Join Date: Mar 2014
Posts: 563
Thank you , if anyone else has had this problem also I would love some tips. I have a good idea of what I need and have to do to fix the issue but tips are always good when your new to an issue!!
mijeeper80 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 04:16 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC