2012 streaming audio quality info - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Tech Forums > Communications and Electronics

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-26-2012, 06:11 PM   #1
Jeeper
 
Join Date: Apr 2011
Posts: 1,694
2012 streaming audio quality info

OK, well you are the first to hear this. I told you that I would let you know when the 2012 Uconnect SW update was released. The dealers received it today. The TSB # is 08-018-12. Below is just the highlight of the TSB. This TSB is for the 2012 vehicles built prior to 1-1-2012 and have the following radios (RES,REQ,RHB,RBZ) and have the Uconnect system. This update has nothing to do with the radio, only the external UC module.
OK, so now you're wondering "can I do the update or do I have to take it to the dealer. Give me a couple days to work on this, I do have the file but I need to call a couple of the dealers to see if they can find it in their STAR system. Once I can confirm that they have it (but probably don't know what to do, even though the procedures will be the same as the TSB from last year and some dealers still claim there is no such TSB) Then I should be able to help further.
Stay tuned.


SYMPTOM/CONDITION:
The customer satisfaction enhancements are included with this software release:
NOTE: After the HFM has been updated it will receive these enhancements.
· Reduced “Device Reading” wait time after connecting a device to the remote USB
port.
· Call / Dial separation improves upon names being recognized as phone numbers.
· Improved sound quality during Bluetooth streaming.
· Increased iPod and iPhone compatibility.
· SMS messaging support via MAP protocol (not all phones support the MAP
protocol).
· Added “None of These” and “Correction” to the phone book prompt menu for better
handling of similar names.
· Previous button will return the song currently being played to the beginning of the
track.
· AirPlay feature “Dock Connector” no longer needs to be manually selected on Apple
devices. This will resolve the “No Audio” condition when the device is connected to
the remote USB port and dock connector is not selected.
NOTE: USB mode resume will no longer 'resume' after ignition OFF

xsdbs is offline   Quote Quick Reply
Old 03-26-2012, 07:12 PM   #2
Jeeper
 
DSmith1178's Avatar
 
Join Date: Jan 2012
Posts: 135
I just got my 2012 JKUR this past Friday. Ive used the bluetooth streaming through my iphone and its sounds outstanding, other than my passenger dash speaker rattle on songs with alot of bass (see my other post on that). With that said, songs on my iphone that were transferred from cd's do sound better than songs ive just downloaded off internet that werent digitally as high in quality so keep that in mind. I have the infinity system with 730 nav. It also syncs up very quickly. Hope this helps others who may have had problems.

Dave

DSmith1178 is offline   Quote Quick Reply
Old 03-26-2012, 07:14 PM   #3
Jeeper
 
seanpholman's Avatar
 
Join Date: Sep 2011
Location: Huntington Beach, CA
Posts: 364
Great info. Those are some nice incremental changes.

--Sean
__________________
Happy Wheeling!
2012 Wrangler Unlimited Sahara Manual
EVO MFG Enforcer 3.5 w/Bilstein 5160s
37-in BFG KM2s
D44s, ARBs, 4.88s
seanpholman is offline   Quote Quick Reply
Old 03-27-2012, 08:23 AM   #4
Jeeper
 
Join Date: Apr 2011
Posts: 1,694
Just curious, what is your build date? This will be on the rivers door tag, (code MHD) Thanks. Yours may already have the new module with this update in it.



Quote:
Originally Posted by DSmith1178 View Post
I just got my 2012 JKUR this past Friday. Ive used the bluetooth streaming through my iphone and its sounds outstanding, other than my passenger dash speaker rattle on songs with alot of bass (see my other post on that). With that said, songs on my iphone that were transferred from cd's do sound better than songs ive just downloaded off internet that werent digitally as high in quality so keep that in mind. I have the infinity system with 730 nav. It also syncs up very quickly. Hope this helps others who may have had problems.

Dave
xsdbs is offline   Quote Quick Reply
Old 03-27-2012, 10:35 AM   #5
Jeeper
 
termite's Avatar
 
Join Date: Feb 2012
Location: Central Ohio
Posts: 623
My build date is 02/06/12 and I do not have any of the issues that the TSB would have addressed. So the "build date prior to 01/01/2012" does appear to be valid.

I'd guess that my radio (430N) has the new update already.

My streaming quality is fantastic and much better than the surprisingly poor Sirius quality.
termite is offline   Quote Quick Reply
Old 03-27-2012, 12:04 PM   #6
Jeeper
 
Join Date: Apr 2011
Posts: 1,694
Thanks for the info on your Jeep. Yes you are completely up to date with your system. The sound quality is what many are waiting for and soon will have.


Quote:
Originally Posted by termite View Post
My build date is 02/06/12 and I do not have any of the issues that the TSB would have addressed. So the "build date prior to 01/01/2012" does appear to be valid.

I'd guess that my radio (430N) has the new update already.

My streaming quality is fantastic and much better than the surprisingly poor Sirius quality.
xsdbs is offline   Quote Quick Reply
Old 03-27-2012, 12:12 PM   #7
Jeeper
 
MPScan's Avatar
 
Join Date: Jan 2012
Location: Boston, MA
Posts: 32
How are you getting this to work? I have a new '12 JKUR, built last month on 2/18/2012 with the 730N radio... and an iPhone 4S... and I CANNOT stream music over Bluetooth. The option is greyed out. It works fine from this phone on my Acura..... ideas?
MPScan is offline   Quote Quick Reply
Old 03-27-2012, 12:29 PM   #8
Jeeper
 
termite's Avatar
 
Join Date: Feb 2012
Location: Central Ohio
Posts: 623
Quote:
Originally Posted by MPScan View Post
How are you getting this to work? I have a new '12 JKUR, built last month on 2/18/2012 with the 730N radio... and an iPhone 4S... and I CANNOT stream music over Bluetooth. The option is greyed out. It works fine from this phone on my Acura..... ideas?
Did you pair the phone? Once in a while my phone, or the 430N does not synch when I first start the Jeep. I sometimes have to hit the phone button on the radio and it will connect with and synch with the phone. It's pretty random.

Mine will show up under aux. It lists my ipod and the the phones name.
termite is offline   Quote Quick Reply
Old 03-27-2012, 02:07 PM   #9
Jeeper
 
DSmith1178's Avatar
 
Join Date: Jan 2012
Posts: 135
XSDBS....My Jeep was built on 3/15. MPScan.. Im using a jailbroken iphone 3gs and have it paired. It works flawlessley. You did properly pair it right? Mine actually comes up on the nav screen under "aux". Says Daves Iphone. Maybe theres still an issue with iphone 4's.

Dave
DSmith1178 is offline   Quote Quick Reply
Old 03-28-2012, 07:10 AM   #10
Jeeper
 
MPScan's Avatar
 
Join Date: Jan 2012
Location: Boston, MA
Posts: 32
Yes, it is paired correctly. I can make/receive calls and the signal strength and battery meter appear correctly on the NAV screen. I am using iOS 5.0.1. on a 4S.

The JK is only a month old, maybe 20 minutes of Google can help me see what's wrong or I should try to delete the phone and re-pair. I'll update later.
MPScan is offline   Quote Quick Reply
Old 03-28-2012, 07:34 AM   #11
Jeeper
 
gossamer917's Avatar
 
Join Date: Sep 2011
Location: CT
Posts: 44
thanks for the info Mine was built in Oct so I am for sure intersted in this..
gossamer917 is offline   Quote Quick Reply
Old 03-28-2012, 08:29 AM   #12
Jeeper
 
Join Date: Apr 2011
Posts: 1,694
Just curious if you have the "airplay" selection at the bottom of the phone? If so you may need to select "Uconnect".


Quote:
Originally Posted by MPScan View Post
Yes, it is paired correctly. I can make/receive calls and the signal strength and battery meter appear correctly on the NAV screen. I am using iOS 5.0.1. on a 4S.

The JK is only a month old, maybe 20 minutes of Google can help me see what's wrong or I should try to delete the phone and re-pair. I'll update later.
Attached Thumbnails
Click image for larger version

Name:	When connected in BTSA mode, some Iphone.jpg
Views:	143
Size:	63.3 KB
ID:	108811  
xsdbs is offline   Quote Quick Reply
Old 04-01-2012, 07:08 PM   #13
Jeeper
 
Join Date: Dec 2011
Location: Milpitas
Posts: 79
Finally!!..thanks for the info. Staying tuned !
sarath is offline   Quote Quick Reply
Old 04-04-2012, 12:20 PM   #14
Jeeper
 
Join Date: Apr 2011
Posts: 1,694
Ok, So here's the file location:
uconnect.upd

and here are the instructions:
Download this file that I have on Mediafire onto a thumb drive and : Place this thumb drive in the USB connector mounted either in the glove box or the center console. Press & release the uconnect phone button and say “set up, software update”. You will start to hear some beeps. This process will take about 20 – 25 minutes. It’s a good size file. During the beeps, the radio screen will in an update mode, when the beeps are done and the screen goes back to the radio then the process should be complete. Just wait for a few seconds after the radio starts to play before removing the thumb drive. Turn the key off, open & close the driver’s door. Wait about 30 seconds then turn the key on. After radio powers up wait about 15 seconds, then press and hold the uconnect phone button for about 15 seconds, the radio will start to say a few options and then something like please attach usb….. And then there will be a software version that comes up on the screen. Should be 63.02.48 V: HS: d2. When you see this
release the button, press and release it again. The radio will show the radio screen now.
You will also need to delete the current pairing of the phone to Uconnect and the Uconnect to the phone, then start the new pairing session.
Let me know how it works out for you. Thank you,

For those with the Iphone 4s, SIRI will not work with the Uconnect system after this update. The reason is the Chrysler had some features changed. (1 of these features Apple rode on to support SIRI) These features were changed in late 2010 and the SW was tested on the phones that were available at that time. The SW was again tested in June of 2011 again with more phones that were available at that time. Chrysler ok'd the SW at that time to start the production of the Uconnect modules. Most of the phone manufactures have and NDA ( this is a legal document known as a "Non Disclosure Application") signed by the suppliers and the phone manufacturer. They will sometime send new prototypes to be tested by the Uconnect supplier. If there are issues, then they both work together to find the fix. Apple does not do this at all, so the only Apple products that can be tested while the Supplier is writing the SW is with the device and its SW that is available at that time. Apple did not come out with the Iphone 4s until October of 2011 which was after the Uconnect modules were built and started to be shipped.
You may ask, "well why did it work in my 2011 or my V1 2012 vehicle. The features & SW were still being worked on for the 2012 vehicles and were not ready to be built for the V1 2012 vehicles, so the V1 was still using the features of the 2011 Uconnect system and the real 2012 Uconnect SW came into play with the V2 vehicle builds. Apple has been notified of this issue more than 4 months ago, so now it's a waiting game to see what they do now.



Quote:
Originally Posted by xsdbs View Post
OK, well you are the first to hear this. I told you that I would let you know when the 2012 Uconnect SW update was released. The dealers received it today. The TSB # is 08-018-12. Below is just the highlight of the TSB. This TSB is for the 2012 vehicles built prior to 1-1-2012 and have the following radios (RES,REQ,RHB,RBZ) and have the Uconnect system. This update has nothing to do with the radio, only the external UC module.
OK, so now you're wondering "can I do the update or do I have to take it to the dealer. Give me a couple days to work on this, I do have the file but I need to call a couple of the dealers to see if they can find it in their STAR system. Once I can confirm that they have it (but probably don't know what to do, even though the procedures will be the same as the TSB from last year and some dealers still claim there is no such TSB) Then I should be able to help further.
Stay tuned.


SYMPTOM/CONDITION:
The customer satisfaction enhancements are included with this software release:
NOTE: After the HFM has been updated it will receive these enhancements.
· Reduced “Device Reading” wait time after connecting a device to the remote USB
port.
· Call / Dial separation improves upon names being recognized as phone numbers.
· Improved sound quality during Bluetooth streaming.
· Increased iPod and iPhone compatibility.
· SMS messaging support via MAP protocol (not all phones support the MAP
protocol).
· Added “None of These” and “Correction” to the phone book prompt menu for better
handling of similar names.
· Previous button will return the song currently being played to the beginning of the
track.
· AirPlay feature “Dock Connector” no longer needs to be manually selected on Apple
devices. This will resolve the “No Audio” condition when the device is connected to
the remote USB port and dock connector is not selected.
NOTE: USB mode resume will no longer 'resume' after ignition OFF
xsdbs is offline   Quote Quick Reply
Old 04-07-2012, 03:40 PM   #15
Jeeper
 
Join Date: Dec 2011
Location: Milpitas
Posts: 79
All done! Took a full 25 mins..went through without at any glitches. I removed the current pairing on Uconnect and in my iPhone before starting the process..so that it starts from scratch once the update is done, probably doesn't matter.

Did a quick test of BT streaming music after that..now there is no obvious degradation of sound quality compared to AUX/Dock connector. Its good bye to those dangling AUX cables...really convenient without sounding bad .

Thanks xsdbs for posting this update here! Saved me a trip to the dealer.
sarath is offline   Quote Quick Reply
Old 04-08-2012, 12:51 PM   #16
Jeeper
 
Join Date: Apr 2011
Posts: 1,694
You're welcome Sarath. Glad that you are now pleased with the sound. If I remember correctly, you had the RES radio. Is that correct?




Quote:
Originally Posted by sarath View Post
All done! Took a full 25 mins..went through without at any glitches. I removed the current pairing on Uconnect and in my iPhone before starting the process..so that it starts from scratch once the update is done, probably doesn't matter.

Did a quick test of BT streaming music after that..now there is no obvious degradation of sound quality compared to AUX/Dock connector. Its good bye to those dangling AUX cables...really convenient without sounding bad .

Thanks xsdbs for posting this update here! Saved me a trip to the dealer.
xsdbs is offline   Quote Quick Reply
Old 04-08-2012, 02:10 PM   #17
Jeeper
 
Join Date: Dec 2011
Location: Milpitas
Posts: 79
Quote:
Originally Posted by xsdbs View Post
You're welcome Sarath. Glad that you are now pleased with the sound. If I remember correctly, you had the RES radio. Is that correct?
Yes. The basic RES with Sirius that comes on 2012 Rubicon.

Its a big relief because I mostly use Spotify on iPhone to listen to music and if I use the USB Dock Connector the controller in the stereo somehow overrides Spotify and starts playing songs from the iTunes. So, I had to use AUX for spotify which I don't prefer due to lack of 'song skip' steering controls and an ugly wire sticking out of the stereo!. Now with bluetooth everything works fine...spotify or iTunes and with steering controls as well!
sarath is offline   Quote Quick Reply
Old 04-09-2012, 08:45 AM   #18
Jeeper
 
gossamer917's Avatar
 
Join Date: Sep 2011
Location: CT
Posts: 44
Hi there,
this might be a silly question but is this only for folks with Iphones?
I have discovered that my Uconnect for some reason does not connect when making a phone call..it goes throught the process, i.e. "call so and so", uconnect responds with the name, mobile option, then nothing happens..so I am wondering if this fix will clear that issue up.

thanks in advance
gossamer917 is offline   Quote Quick Reply
Old 04-09-2012, 09:07 AM   #19
Jeeper
 
Join Date: Apr 2011
Posts: 1,694
Hello, this update is more of an enhancement for uconnect. Some phones work better because of it. What phone do you have? Uconnect won't drop the call. The phone is in control of all connections.


Quote:
Originally Posted by gossamer917 View Post
Hi there,
this might be a silly question but is this only for folks with Iphones?
I have discovered that my Uconnect for some reason does not connect when making a phone call..it goes throught the process, i.e. "call so and so", uconnect responds with the name, mobile option, then nothing happens..so I am wondering if this fix will clear that issue up.

thanks in advance
xsdbs is offline   Quote Quick Reply
Old 04-09-2012, 09:14 AM   #20
Jeeper
 
Iamjrad79's Avatar
 
Join Date: Apr 2012
Location: Fairbanks, AK
Posts: 97
The instructions say to load the file onto a thumbdrive, but my JKU doesn't have a USB port. I have the RES/RSC radio. How can I get the update without a USB port?
__________________
Every man dies, but only Jeep owners live
Iamjrad79 is offline   Quote Quick Reply
Old 04-09-2012, 11:35 AM   #21
Jeeper
 
Join Date: Apr 2011
Posts: 1,694
First, is your Uconnect system factory installed or is it the Mopar kit installed at the dealer? If it's a factory installed system, there should be a USB hub in the center console. If it is dealer installed, then you will need the iPod / USB cable PN 82212160 (it's about $35). The dealer sells this as an optional cable to the kit. Problem is that even if you don't plan on using an iPod, you still need it for updates.





Quote:
Originally Posted by Iamjrad79 View Post
The instructions say to load the file onto a thumbdrive, but my JKU doesn't have a USB port. I have the RES/RSC radio. How can I get the update without a USB port?
xsdbs is offline   Quote Quick Reply
Old 04-09-2012, 11:45 AM   #22
Jeeper
 
Iamjrad79's Avatar
 
Join Date: Apr 2012
Location: Fairbanks, AK
Posts: 97
It's factory installed but I didn't see the USB port. I'll take a closer look and see if it's hiding somewhere. If not I'll look into the cable. Thanks!
__________________
Every man dies, but only Jeep owners live
Iamjrad79 is offline   Quote Quick Reply
Old 04-10-2012, 06:56 AM   #23
Jeeper
 
gossamer917's Avatar
 
Join Date: Sep 2011
Location: CT
Posts: 44
Quote:
Originally Posted by xsdbs View Post
Hello, this update is more of an enhancement for uconnect. Some phones work better because of it. What phone do you have? Uconnect won't drop the call. The phone is in control of all connections.
Good morning,
I have an LG Enlighten..I hate it but my phone died and I had to get a new one quickly..anyway, I can receive calls just fine, I can make calls if I manually select the person via the phone, but when using "talking" to the Uconnect, the call just doesn't go through..very frustrating.

thanks for responding
Hannah
gossamer917 is offline   Quote Quick Reply
Old 04-10-2012, 08:12 AM   #24
Jeeper
 
Join Date: Apr 2011
Posts: 1,694
Hanna, Can you explain this with a little more detail please. If you say "dial ###-####" does UC reply back with "dialing ###-####........"? Does UC dial the number and then doesn't go thru? This may be a lame question & I apologize in advance. Which button are you pressing when you are trying to make the call? (you're phrase "but when using "talking" to the Uconnect" is a little confusing).



Quote:
Originally Posted by gossamer917 View Post
Good morning,
I have an LG Enlighten..I hate it but my phone died and I had to get a new one quickly..anyway, I can receive calls just fine, I can make calls if I manually select the person via the phone, but when using "talking" to the Uconnect, the call just doesn't go through..very frustrating.

thanks for responding
Hannah
xsdbs is offline   Quote Quick Reply
Old 04-10-2012, 08:52 AM   #25
Jeeper
 
Join Date: Apr 2011
Posts: 1,694
Ok, If it's factory installed, there should be a USB connector in the center console. It should also light up when the radio is powered up.


Quote:
Originally Posted by Iamjrad79 View Post
It's factory installed but I didn't see the USB port. I'll take a closer look and see if it's hiding somewhere. If not I'll look into the cable. Thanks!
xsdbs is offline   Quote Quick Reply
Old 04-10-2012, 09:35 AM   #26
Jeeper
 
gossamer917's Avatar
 
Join Date: Sep 2011
Location: CT
Posts: 44
Quote:
Originally Posted by xsdbs View Post
Hanna, Can you explain this with a little more detail please. If you say "dial ###-####" does UC reply back with "dialing ###-####........"? Does UC dial the number and then doesn't go thru? This may be a lame question & I apologize in advance. Which button are you pressing when you are trying to make the call? (you're phrase "but when using "talking" to the Uconnect" is a little confusing).
Sorry, my brain was working faster than my fingers this morning.

Lets say I want to call the BF, I hit the phone button on my dash, UC starts talking, I then say, "call so and so", UC responds with the persons name, UC asks if dialing the mobile number is correct, I say either yes or correct..and then nothing happens..
gossamer917 is offline   Quote Quick Reply
Old 04-11-2012, 07:59 AM   #27
Jeeper
 
Join Date: Apr 2011
Posts: 1,694
Hanna,
Can you try a different phone to see if it acts the same. You see, Uconnect will take your message and send it to the phone to place a call, then the phone should react and make the call as well as send a message back to the UC saying that it's placing the call. If UC doesn't get the massage from the phone then it cancels.
After you say "yes", and then the system does nothing, does the radio stay in the hands free mode or does it go back to the radio screen?



Quote:
Originally Posted by gossamer917 View Post
Sorry, my brain was working faster than my fingers this morning.

Lets say I want to call the BF, I hit the phone button on my dash, UC starts talking, I then say, "call so and so", UC responds with the persons name, UC asks if dialing the mobile number is correct, I say either yes or correct..and then nothing happens..
xsdbs is offline   Quote Quick Reply
Old 04-12-2012, 07:29 AM   #28
Jeeper
 
gossamer917's Avatar
 
Join Date: Sep 2011
Location: CT
Posts: 44
Quote:
Originally Posted by xsdbs View Post
Hanna,
Can you try a different phone to see if it acts the same. You see, Uconnect will take your message and send it to the phone to place a call, then the phone should react and make the call as well as send a message back to the UC saying that it's placing the call. If UC doesn't get the massage from the phone then it cancels.
After you say "yes", and then the system does nothing, does the radio stay in the hands free mode or does it go back to the radio screen?
Good morning,

I will try a different phone this weekend. After I say yes, the radio goes right back to the radio screen..
gossamer917 is offline   Quote Quick Reply
Old 04-13-2012, 07:56 AM   #29
Jeeper
 
Join Date: Apr 2011
Posts: 1,694
Great, let me know when you've tried a different phone, ok.


Quote:
Originally Posted by gossamer917 View Post
Good morning,

I will try a different phone this weekend. After I say yes, the radio goes right back to the radio screen..
xsdbs is offline   Quote Quick Reply
Old 04-14-2012, 01:09 PM   #30
Jeeper
 
americonium's Avatar
 
Join Date: Apr 2012
Location: 11762
Posts: 387
I am going to subscribe to this thread, because the dealership is installing the U-connect on Monday, and I want to make sure that it is updated before I leave. Thank you for posting this information, it really will make me a happier Jeep owner.

americonium is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
AFE Cat Back Exhaust, CAI, Ypipe dyno 2012 rubicon PieFace JK General Discussion Forum 315 12-06-2013 03:39 PM
Nissan Patrol safari 4.8 SWB 2012 or JK 3.6 SWB 2012 kyakobi JK General Discussion Forum 30 01-11-2013 04:38 PM
Recalibrate the 2012 TyJeep97 JK General Discussion Forum 18 07-06-2012 06:17 PM
Spring Sale! Jeep TJ & JK Wrangler Tube Doors 1997-2012 as low as $217.95 shipped Baseline 4x4 Outfitters Vendor Spotlight! Great Deals for Members. 7 04-27-2012 07:20 PM
First TJ topless pics of 2012!!! JeepinDave TJ General Discussion Forum 204 04-09-2012 11:28 AM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 08:18 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC