Amp working but speakers and sub dont - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-28-2012, 11:52 AM   #1
Jeeper
 
LouieDelTorchio's Avatar
 
Join Date: Nov 2011
Location: Sacramento, CA
Posts: 1,221
Images: 1
Send a message via MSN to LouieDelTorchio Send a message via Skype™ to LouieDelTorchio
Amp working but speakers and sub dont

So lets start out with what I have.
Headunit: Pioneer DEH-3200UB
Soundbar Speakers: 6.5" Polk DBs
Subwoofer: JL 10" in custom box
Amp: Jensen 760 watt 4 channel

I hooked up the amp, got a good ground, power and remote. Green light is on. Put the two sets of RCAs in, R/SUB to channel 3 and 4 because i am bridging those channels. Then i ran another set of RCAs from the front to channels 1 and 2 for the speakers up top. I have channels 1 and 2 set to full and 3 and 4 to Low. Im getting no sound from the speakers or sub. Im not sure what i did wrong. I tried messing with the headunit setting but it didnt seem to work. On the way to starbucks today i was listening to my front speakers running off my headunit, but i started hearing a really quiet sound from the speaker above me. Any advice would be very appreciated!

__________________
Louie Del Torchio
LouieDelTorchio is offline   Quote Quick Reply
Old 10-28-2012, 12:03 PM   #2
Newb
 
Hardheadedgoat's Avatar
 
Join Date: Oct 2012
Posts: 4
Id hit craigslist and get a better brand of amp ive never had luck with the cheaper brands.. I have an infinity bass link in my tj n it quit so I thought it was the amp or rca cables turns out it was the cheap stereo that I had

Hardheadedgoat is offline   Quote Quick Reply
Old 10-28-2012, 12:10 PM   #3
Jeeper
 
LouieDelTorchio's Avatar
 
Join Date: Nov 2011
Location: Sacramento, CA
Posts: 1,221
Images: 1
Send a message via MSN to LouieDelTorchio Send a message via Skype™ to LouieDelTorchio
I got it for free so i wasnt expecting much haha
__________________
Louie Del Torchio
LouieDelTorchio is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 04:41 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC