amplifier not working - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics

Join Wrangler Forum Today



Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-08-2012, 01:23 PM   #1
Jeeper
 
stretch05's Avatar
 
Join Date: Dec 2011
Posts: 313
stretch05 is on a distinguished road
amplifier not working

I took my Jeep in for an oil change and had them check the brakes also. When i picked it up, the sub wasn't working. I'm checking connections and everything is good. I replaced the remote lead and the RCA. I checked the fuse and it was fine. When I turn on the power, the "power/ protect led" flashes red and turns off. The manual says red means short circuit/low impedance is detected at the speaker connections. Any ideas?


Rockford fosgate punch pbr300x1 mono

Pioneer 10" sub
__________________
1992 Wangler YJ 4.0 HO
stretch05 is offline   Quote
Old 04-08-2012, 01:33 PM   #2
Jeeper
 
Q_The_Cop's Avatar
 
Join Date: Sep 2009
Location: Milledgeville, GA
Posts: 109
Q_The_Cop is on a distinguished road
Send a message via Yahoo to Q_The_Cop
I had a pioneer amp do that to me and it turned out my ground had come a little loose. Sounds like I'd be yelling at some high school oil checkers! Maybe they were jamming in the bay and blew it. LOL!

__________________


It is no coincidence that in no known language does the phrase 'As pretty as an Airport' appear. ~ Douglas Adams
Q_The_Cop is offline   Quote
Old 04-08-2012, 01:45 PM   #3
Jeeper
 
stretch05's Avatar
 
Join Date: Dec 2011
Posts: 313
stretch05 is on a distinguished road
Checked the ground. It the same as it always was. Working fine. Checked the power wire too and it's fine.
__________________
1992 Wangler YJ 4.0 HO
stretch05 is offline   Quote
Old 04-08-2012, 01:50 PM   #4
Jeeper
 
Jma20a's Avatar
 
Join Date: Apr 2007
Location: Fairfield, CT
Posts: 3,046
Jma20a is on a distinguished road
What r the ohms on both sub and amp. If the Sub has a lower ohm rating than the amp can handle u will blow your amp.
__________________
Dear Algebra, Please stop asking us to find your X. She's never coming back and don't ask Y.
Jma20a is offline   Quote
Old 04-08-2012, 02:02 PM   #5
Jeeper
 
stretch05's Avatar
 
Join Date: Dec 2011
Posts: 313
stretch05 is on a distinguished road
Amp is 1-4 ohms and the sub is 4
__________________
1992 Wangler YJ 4.0 HO
stretch05 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Not Enough Jeeps in AfganyLand natepilla Off-Topic 79 10-17-2013 01:05 AM
My amplifier install Pukeolicious YJ Tech Forum 16 12-10-2012 02:08 AM
Why soundbar won't sound good with stock amplifier ronrad JK General Discussion Forum 90 07-04-2012 02:23 PM
Tj not shifting AFGUY1980 TJ General Discussion Forum 12 04-11-2012 12:13 PM
11' JK remotes stopped working? SaltySeats JK General Discussion Forum 6 04-08-2012 10:25 AM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 01:08 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC