BT Streaming not working with 730N and iOS7 - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Tech Forums > Communications and Electronics

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-08-2013, 01:47 PM   #1
Jeeper
 
TxWarEagle's Avatar
 
Join Date: Aug 2012
Location: Central Texas
Posts: 37
BT Streaming not working with 730N and iOS7

(Before I get started with my question, I'm going to lay all my cards on the table and admit that I ABSOLUTELY HATE the 730N. IMO it's the biggest piece of crap radio/nav I've ever used (and I rent a lot of cars, so I've used almost all of them). At this point, I think I would've gotten more satisfaction out of taking the $3K I paid for this POS and literally burning it in my driveway.)

Anyway, that being said, I cannot get the bluetooth streaming to work reliably between my iPhone 5 and 730N recently. The only thing that I can think has changed was the upgrade to iOS7, so I don't know if that's the culprit or not.

Never had TOO many problems with it in the past, but now it will queue up and start playing (after giving the 730N it's required 5-10 minutes to recognize there is a BT device in the vehicle and connect). Then, after about 30 seconds the stream stops and the onscreen data for whatever I was listening to goes away. When I try to reconnect, it just keeps saying "Failed to Play."

BT phone calls still work, but that's it. I'd say 90% of the time I listen to either podscasts or music from my phone, so losing this functionality has me screaming at this POS even more than usual.

Sorry for the bitterness, it's pure frustration!

Any advice?!?

TxWarEagle is offline   Quote Quick Reply
Old 10-09-2013, 05:37 AM   #2
Jeeper
 
Join Date: Jan 2013
Posts: 320
Sell the 730, you can still find a sucker that wants "stock" and will be willing to pay handsomely for that 730.

Buy and aftermarket head unit that has the features you want, works better, has a better UI, sounds better and costs less.

You may be able to recoup most of the cost through the sale of your 730.

You will probably be starting in a journey to replace your entire sound system, but you won't be disappointed.

Mattk11 is online now   Quote Quick Reply
Old 10-09-2013, 10:23 AM   #3
Jeeper
 
TxWarEagle's Avatar
 
Join Date: Aug 2012
Location: Central Texas
Posts: 37
Thanks Matt. That's pretty much where I'm at now (selling the 730). I've actually already upgraded everything else in the Jeep (Dash/Soundbar Speakers/Tweeters, New Sub & Amp in a custom box & added a JL Cleansweep), the only reason I left the 730 alone was to maintain a stock appearance when running without doors/top, but the frustration of dealing with this thing has pretty much negated that one advantage.

The last thing I may try is to get my Dealer to swap it out under warranty with the hopes that maybe I just got a lemon? (But I suspect they'll just blame my problems on the aftermarket stuff I've done). So I don't have a lot of hope for this solution.

Any recommendations on an aftermarket head-unit if I do bite the bullet?
TxWarEagle is offline   Quote Quick Reply
Old 10-10-2013, 12:38 AM   #4
Jeeper
 
Join Date: Jan 2013
Posts: 320
Man if you already changed everything out you will hear a gigantic difference when you switch to an aftermarket head unit. It will be dramatic.

I'm using a Pioneer x8500Bhs. It's not a Nav unit and it had its flaws, mostly because of iPhone 5 video cables. But for UI, steering wheel integration, iPhone music, pandora, Bluetooth etc, it is very good.

I chose it because the face is removable so when I park with the top and/or doors off there is nothing to steal. I would bet Kenwood and Alpine make something similar.

Don't forget when you sell the 730, you can also sell the Cleansweep. You won't need it with an aftermarket HU. Boom, you just paid for your new HU.
Mattk11 is online now   Quote Quick Reply
Old 10-11-2013, 07:31 AM   #5
Jeeper
 
detajr's Avatar
 
Join Date: Aug 2013
Location: The Ocean State
Posts: 67
The problem is in the U-connect system.
I sent an email to Jeep/Uconnect about this streaming problem.
I was told that the iPhone and iPod are not 100 percent compatible with Uconnect.
There is no fix. Why they didn't make this thing compatible with the NUMBER 1 phone in the world...WHO KNOWS!!!!!
detajr is offline   Quote Quick Reply
Old 10-11-2013, 07:24 PM   #6
Jeeper
 
Join Date: Nov 2012
Posts: 156
Quote:
Originally Posted by detajr View Post
I was told that the iPhone and iPod are not 100 percent compatible with Uconnect.
There is no fix.
This got me laughing. I've got a Galaxy S4 and though it works fantastic most of the time I've got to re-pair it with the HU every few weeks it seems. Total PITA.

I was dead set on keeping my HU and installing an LOC, but after digging deep I see it's not the best solution. It sounds like aftermarket headunits are just better all around, full range sound w/o crossovers, BT that works... and with an Axxcess device all the steering wheel controls can still be used, phone too.

Now someone needs to fab up a solid security device. Like that Tuffy thing but not so ugly.
OffRoadWarrior is offline   Quote Quick Reply
Old 10-12-2013, 03:14 AM   #7
Jeeper
 
Join Date: Jan 2013
Posts: 320
Quote:
Originally Posted by OffRoadWarrior View Post
This got me laughing. I've got a Galaxy S4 and though it works fantastic most of the time I've got to re-pair it with the HU every few weeks it seems. Total PITA. I was dead set on keeping my HU and installing an LOC, but after digging deep I see it's not the best solution. It sounds like aftermarket headunits are just better all around, full range sound w/o crossovers, BT that works... and with an Axxcess device all the steering wheel controls can still be used, phone too. Now someone needs to fab up a solid security device. Like that Tuffy thing but not so ugly.
Just get a head unit with a removable face. There are double DINs that are removable. Boom
Mattk11 is online now   Quote Quick Reply
Old 10-14-2013, 06:20 AM   #8
Jeeper
 
Join Date: Apr 2011
Posts: 1,682
"#1 phone in the world"? Quite questionable.
I'm kind of really curious on how you think that a MFG can build a product that will be compatible a device that changes SW yearly (and at times less than a year). A product is developed to work with devices that are currently in the market. The phone companies don't come out and say "here's what we have now and by the way, here's what we plan on coming out with in the future". Just remember what changed here. The phones SW not the Uconnect SW. So perhaps, APPLE should have done more SW validation before releasing the iOS7.



Quote:
Originally Posted by detajr View Post
The problem is in the U-connect system.
I sent an email to Jeep/Uconnect about this streaming problem.
I was told that the iPhone and iPod are not 100 percent compatible with Uconnect.
There is no fix. Why they didn't make this thing compatible with the NUMBER 1 phone in the world...WHO KNOWS!!!!!
xsdbs is offline   Quote Quick Reply
Old 10-14-2013, 06:23 AM   #9
Jeeper
 
Join Date: Apr 2011
Posts: 1,682
I would suggest you deleting the pairing of the phone to Uconnect, and Uconnect from the phone. Then reboot the phone by holding the power & home buttons till the apple appears, then release them. The phone will now reboot. Now perform a fresh pairing session.



Quote:
Originally Posted by TxWarEagle View Post
(Before I get started with my question, I'm going to lay all my cards on the table and admit that I ABSOLUTELY HATE the 730N. IMO it's the biggest piece of crap radio/nav I've ever used (and I rent a lot of cars, so I've used almost all of them). At this point, I think I would've gotten more satisfaction out of taking the $3K I paid for this POS and literally burning it in my driveway.)

Anyway, that being said, I cannot get the bluetooth streaming to work reliably between my iPhone 5 and 730N recently. The only thing that I can think has changed was the upgrade to iOS7, so I don't know if that's the culprit or not.

Never had TOO many problems with it in the past, but now it will queue up and start playing (after giving the 730N it's required 5-10 minutes to recognize there is a BT device in the vehicle and connect). Then, after about 30 seconds the stream stops and the onscreen data for whatever I was listening to goes away. When I try to reconnect, it just keeps saying "Failed to Play."

BT phone calls still work, but that's it. I'd say 90% of the time I listen to either podscasts or music from my phone, so losing this functionality has me screaming at this POS even more than usual.

Sorry for the bitterness, it's pure frustration!

Any advice?!?
xsdbs is offline   Quote Quick Reply
Old 10-14-2013, 11:43 AM   #10
Jeeper
 
Greystreetjku14's Avatar
 
Join Date: Aug 2013
Location: Monmouth Cnty NJ
Posts: 305
Quote:
Originally Posted by xsdbs View Post
I would suggest you deleting the pairing of the phone to Uconnect, and Uconnect from the phone. Then reboot the phone by holding the power & home buttons till the apple appears, then release them. The phone will now reboot. Now perform a fresh pairing session.
^^^^ this is probably your best answer. My wife tried to do hers, and it wouldn't work, i reset the phone, reconnected, and now it works perfectly.

and if i remember the quote in a general fashion, wasn't it apple that said something like "we are big enough for people to conform to us, not us to conform to them"
Greystreetjku14 is offline   Quote Quick Reply
Old 10-15-2013, 07:16 AM   #11
Jeeper
 
Join Date: Apr 2011
Posts: 1,682
Yeah and how many corporations were too big to fail?




Quote:
Originally Posted by Greystreetjku14 View Post
^^^^ this is probably your best answer. My wife tried to do hers, and it wouldn't work, i reset the phone, reconnected, and now it works perfectly.

and if i remember the quote in a general fashion, wasn't it apple that said something like "we are big enough for people to conform to us, not us to conform to them"

xsdbs is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 10:09 PM.



Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC