CB issues - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-22-2010, 08:52 PM   #1
Jeeper
 
Join Date: Jun 2009
Posts: 126
CB issues

I have a Cobra 19 DX IV with 20' of cable and a radio shack 48" fiberglass antenna. i finally have the radio wired up and when i go to tune it the SWR is sitting in the red and i mean way red. my question's are is 20' to much cable? does anyone know if this antenna is suppose to be grounded? the mount i picked up has a plastic bushing that wont let the metal mount touch the steel of my tire carrier. and last is could i have a faulty radio? i picked this one up on clearance because the brackets were missing.

thanks

RhcSavage21 is offline   Quote
Old 03-22-2010, 08:58 PM   #2
Ugly Supporting Member

WF Supporting Member
 
PecosRiver's Avatar
 
Join Date: Jan 2010
Location: San Jose, New Mexico
Posts: 1,546
Radio Shack has brackets.

PecosRiver is offline   Quote
Old 03-22-2010, 09:03 PM   #3
Jeeper
 
Join Date: Oct 2006
Location: Eastern IA
Posts: 217
Check out this link. There is a ton of good info there. Tech-Docs Index
Whobeme is offline   Quote
Old 03-22-2010, 09:04 PM   #4
Jeeper
 
Join Date: Jun 2009
Posts: 126
i made the brackets to mount the radio, the mic one i got from radio shack. i will look at that link. but should the antenna be grounded?
RhcSavage21 is offline   Quote
Old 03-22-2010, 09:14 PM   #5
Jeeper
 
Join Date: Oct 2006
Location: Eastern IA
Posts: 217
Here's a link to a pic of how it should be. Radio Antenna Mount Details
Whobeme is offline   Quote
Old 03-22-2010, 09:15 PM   #6
Jeeper
 
whiteyj's Avatar
 
Join Date: Jul 2005
Location: Pleasanton CA
Posts: 4,860
No. The insulator is there for a reason.
__________________
Fallen Angel...Former MOD......Yeah no 10 yr pin in my mailbox.............
whiteyj is offline   Quote
Old 06-27-2010, 06:37 AM   #7
Jeeper
 
cru9's Avatar
 
Join Date: Apr 2010
Location: Ellijay, Georgia
Posts: 469
Images: 1
If there is extra cable that you have rolledup make sure it is rolled in a big lose loop
cru9 is offline   Quote
Old 06-27-2010, 09:31 AM   #8
Jeeper
 
Join Date: Jun 2010
Location: Slammin Salmon in Alaska
Posts: 1,997
I would use a Wilson 1000 antenna. One of the best made. I had trouble with a couple of Radio Shack antennas
__________________
FaceBook Jeep'n Alaska
Ted_D is offline   Quote
Old 06-27-2010, 12:01 PM   #9
Jeeper
 
skeeter's Avatar
 
Join Date: Dec 2006
Location: Spokane, Wa.
Posts: 3,898
Send a message via Yahoo to skeeter
The coax shielding should be grounded and will be if you mount the antenna properly.
You could have a bad radio, bad coax, bad antenna or bad ground.
Start with ground, make sure your antenna is mounted correctly per the link posted above.
Make sure your tire carrier is grounded to the body. Make sure the body ground straps are in good condition.
Next, make sure your swr meter is working properly, try it on another radio if you can or try a different swr meter.
Next, I would get a shorter piece of coax. As posted above, don't roll up any extra in loops.
Make sure you're getting about a third or more antenna above your roof line.

__________________
"But it does me no injury for my neighbour to say there are twenty gods, or no god. It neither picks my pocket nor breaks my leg." - Thomas Jefferson, Notes on the State of Virginia, 1782

Arguing with a truck driver is like wrestling with a pig in mud, eventually you realize the pig enjoys it.
skeeter is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
92 wrangler clutch/transmission issues jubilee YJ Tech Forum 0 12-29-2009 10:36 PM
New to me 06 LJ Rubicon 37K issues.... kmorris283 TJ General Discussion Forum 5 07-31-2009 05:31 PM
Brake issues... lap49X TJ Tech Forum 19 11-21-2008 11:23 PM
similar tj perf issues tucson97 TJ General Discussion Forum 2 10-15-2005 05:46 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 03:27 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC