Cobra 75 Tx no Rx - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-25-2013, 02:45 PM   #1
DaK
Jeeper
 
Join Date: Feb 2012
Location: Lancaster, CA
Posts: 1,432
Cobra 75 Tx no Rx

Started having this problem about a month ago. At first comms were just scratchy, couldn't hear well on the Rx but everyone stated they could hear me fine. Then, nothing on the Rx, not even static. Though the "head" unit could be bad so ordered up another one, same problem.

Ran through the steps on this website:

CB Radio Articles: Selection | Installation | Troubleshooting

All checks were good. That is to say, opens where opens should be, shorts where shorts should be. Connected system directly to the battery and achieved the same results, no Rx, no static, nuttin except the backlighting. So power is not the problem.

Antenna and mount check good with IAW the firestick website.

Testing Continuity -- 1996 Firestik&#174 Antenna Company

Have the left most set up.

Another thing we don't get is when the CB is turned on you normally get "tones". Nothing there. Would suspect another bad "head" unit but my thought is that two bad units should be near impossible to achieve.

Antenna is mounted on a Rockhard tire carrier which as previously stated, worked fine till about a month ago.

Any and all insight welcomed. Seriously thinking about cashing this for a Uniden....

DaK is offline   Quote
Old 08-25-2013, 03:39 PM   #2
Newb
 
Join Date: Feb 2012
Posts: 9
Sounds like the speaker is out? Had that happen once. Sat in the hot car too many months, speaker got progressively fuzzy, then nothing. If you have a remote speaker, check the wiring. You should also be able to plug in an earphone to the external speaker/PA jack. If you dont hear anything, probably the driver transistors went out. Good luck.
bigal66 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 09:07 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC