Dashboard, turn signal and brake lights all go out at once? - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-30-2011, 02:48 PM   #1
Newb
 
Join Date: Mar 2011
Location: Wheaton, IL
Posts: 13
Dashboard, turn signal and brake lights all go out at once?

Beginning problem: Brake lights, dashboard lights and turn signals all go out at once.

Current problems: I fixed the brake lights and turn signals (just by changing the bulbs) but the dashboard does not light up. The icons (turn signals, brake light, check engine light....) work fine but when I turn on my headlights the dashboard doesn't light up. And my check engine light is on just to top it off.

How it happened: I was just driving around town for a half hour and everything was fine, put the parking brake on to run into the house for a second. When I come back the car is still running but all the lights are off except the check engine light.

Most likely the cause: So I bought a subwoofer and a new headunit and installed it myself. In order to install the 2 new parts I had to cut some wires behind the dashboard.

What I did to fix it:
1. Checked the fuses behind the glove box. The turn signal fuse was blown so i replaced it then check it by putting the turn signal on and it worked. Then I put the hazard lights on and the fuse blew again.

2. Replaced all the light bulbs. All the bulbs looked fine but I did it anyways and it fixed my brake lights and turn signal problem.

3. Checked fuses under the hood. Everything was fine.

4. Rechecked my entry level wiring job. I figured I must have accidently grounded/not fully covered some wire-that seemed to be the only explination if 3 seperate electrical things went out. But it was fine.

dandewitt97 is offline   Quote
Old 03-30-2011, 03:07 PM   #2
Jeeper
 
TOKKIE's Avatar
 
Join Date: Mar 2010
Location: Sonora, CA.
Posts: 415
The dash lights not turning on is usually an indication that the running lights are not comming on. This is to let you know when the running lights are not working, I would check the fuse for running lights. I'm assuming the dimmer is turned up.

TOKKIE is offline   Quote
Old 03-30-2011, 03:10 PM   #3
Jeeper
 
jefferyfghezzi's Avatar
 
Join Date: Jan 2011
Location: SANDUSKY OHIO
Posts: 641
Do you use your parking brake very often? could you have a short in the PARKING BRAKE SWITCH? After your installation all was well until you used the parking brake. What wires did you cut?The ones that went to the head unit?
jefferyfghezzi is offline   Quote
Old 03-30-2011, 06:50 PM   #4
Newb
 
Join Date: Mar 2011
Location: Wheaton, IL
Posts: 13
The dimmer is up.

All the wires that I cut were related to the head unit, they were all directly behind the dashboard and connected to the old radio. I wanted to play my ipod through my "new" head unit that was made in 1999 so it took some wiring that isn't exactly by the book. But I had my ipod/new head unit for about a month before any of these problems started; and my subwoofer was installed (by me) a few days with no problems.

I use my parking brake a lot. When I was working on it I had the car running for a little with the parking brake on and the brake/turn signals continued to work.

I have seriously checked every fuse in both fuse boxes. I figured I took power from the lights in order to power the sub on accident but since the lights worked after I wired the sub, that cant be it.

Im thinking it has to have something to do with the way I did the sub. I am going to recheck that tomorrow unless someone has another suggestion for me.
dandewitt97 is offline   Quote
Old 03-30-2011, 07:46 PM   #5
Newb
 
Join Date: Mar 2011
Location: Wheaton, IL
Posts: 13
So I just got back from autozone and I had them see why my check engine light is on. They said I have a oxygen sensor problem (P0133). I mentioned that I screwed around with the wires but they promised me it has nothing to do with it. No wonder this was so hard to fix, it is totally unrelated and just has extremely annoying timing. Now I just need to get those dashboard lights working and Ill be in good shape.
dandewitt97 is offline   Quote
Reply

Tags
dash lights , electrical problem

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Right Turn Signal on when Brake Pushed? CJ2WRANGLER TJ General Discussion Forum 7 04-29-2011 01:03 PM
Brake Light/Turn Signal Malfunction YJKarjala YJ Tech Forum 12 03-25-2011 01:21 AM
Turn signal lights jakecarroll87 TJ Tech Forum 4 10-27-2010 11:40 AM
Signal and brake lights just quit working fullboar01 YJ General Discussion Forum 6 03-14-2010 10:58 PM
Turn Signal Grounding issue? MrMiyagi TJ Tech Forum 1 09-15-2009 05:26 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 03:58 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC