Finally got my electric gadgets installed. - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-13-2013, 01:55 PM   #1
Jeeper
 
dundonm's Avatar
 
Join Date: Jan 2013
Location: Kansas
Posts: 33
Images: 1
Finally got my electric gadgets installed.

I have my phone, tablet, cb and sat radio finally installed. Everything is easily viewable and within reach. Took some time but it works for me. I just got the superchips LINQ which I run on the tablet, and CoPilot GPS. The phone I run Torque and well easy place for my phone. I have the 130 radio but only listen to sat radio. I can reach the volume knob just fine. And the cb is easy to reach and hear. I made or pieced together every mount.

Click image for larger version

Name:	ForumRunner_20130513_135436.jpg
Views:	77
Size:	86.9 KB
ID:	248702

__________________
2008 JK X, 4.10 gears, Lockers, Mopar winch bumper with a Warn 9.5ti, Mopar rear bumper, Discos, 33x12.5x17 MTZs on DC1 rims. 6 speed, Coil Spacers.
dundonm is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 10:51 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC