Head unit turns on, speakers don't play - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-29-2011, 09:56 PM   #1
Doesn't know much

WF Supporting Member
 
YHSublime's Avatar
 
Join Date: Oct 2010
Location: Arlington, VA
Posts: 456
Send a message via AIM to YHSublime
Head unit turns on, speakers don't play

So I had my Wrangler out in the rain the other day (pretty heavy) for a couple hours. I was also out for a couple hours and couldn't put my top up. Next day, I went to go put my faceplate on (this was not subject to the storm) and listen to some tunes. Well, the head unit turns on, and even beeps (the system, not the speakers) but it wont pump music out the speakers. When I turn the volume up all the way, i can hear my speakers crackle, if you will. Had anybody had this happen before? I checked the wiring, and everything seems connected still, and the fuse in the back of the unit is still intact. The top of the unit was a little more than damp though when I pulled it out, it just seems strange that everything else would work...

Any thoughts or ideas?

YHSublime is offline   Quote Quick Reply
Old 08-29-2011, 11:04 PM   #2
Jeeper
 
Jma20a's Avatar
 
Join Date: Apr 2007
Location: Fairfield, CT
Posts: 3,046
on some units it only takes a few drops of water to harm a head unit. thats why i always have a towel to toss over the unit when i didnt have my doors with me in a storm. you may be SOOL, check your warranty and see if there is anything in there to help you out, there is a 98% chance you are SOOL

__________________
Dear Algebra, Please stop asking us to find your X. She's never coming back and don't ask Y.
Jma20a is offline   Quote Quick Reply
Old 08-29-2011, 11:10 PM   #3
Doesn't know much

WF Supporting Member
 
YHSublime's Avatar
 
Join Date: Oct 2010
Location: Arlington, VA
Posts: 456
Send a message via AIM to YHSublime
Yeaaaaaaah, womp womp. I figured it was probably the headunit. I would have put the top up before i went out, but it was one of those hindsight deals. Not a cloud in the sky, beautiful weather. Then when I was about two hours away, torrential rain. No big deal, but I'll probably just get the same one so I can plug and play, no tunes make me a dull boy.
YHSublime is offline   Quote Quick Reply
Old 08-30-2011, 12:07 PM   #4
Jeeper
 
Jma20a's Avatar
 
Join Date: Apr 2007
Location: Fairfield, CT
Posts: 3,046
yeah im in new england and around here they say if you don't like the weather wait ten minutes. is the unit under warranty?
__________________
Dear Algebra, Please stop asking us to find your X. She's never coming back and don't ask Y.
Jma20a is offline   Quote Quick Reply
Old 08-30-2011, 10:26 PM   #5
Doesn't know much

WF Supporting Member
 
YHSublime's Avatar
 
Join Date: Oct 2010
Location: Arlington, VA
Posts: 456
Send a message via AIM to YHSublime
Maybe. I got it for this last xmas, and it's an Alpine something or the other. I'll check, i think I have everything lying around somewhere.
YHSublime is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Head Unit won't turn on anymore?? BlackMountain JK General Discussion Forum 17 05-15-2011 05:17 PM
Speakers for Alpine unit?? Ted_D Communications and Electronics 8 03-04-2011 02:03 PM
Overheating? Turns out it was the sending unit! joshd4 YJ Tech Forum 0 02-16-2011 09:21 AM
2011 JK Stereo head unit replace? CiscoJK JK General Discussion Forum 0 11-12-2010 07:28 PM
What speakers sound good with Pioneer head unit? YJman Communications and Electronics 63 10-31-2010 09:33 AM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 12:58 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC