HELP - Radio blowing fuse problem - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-21-2013, 11:52 PM   #1
Jeeper
 
Tyler's Avatar
 
Join Date: Jan 2013
Location: Arizona
Posts: 43
HELP - Radio blowing fuse problem

Hello,

My radio I've had for years is finally showing me some problems. I installed it myself and have transferred it from my old car into my TJ.

What happened:

I was offroading and on my way out of the trail my radio just turned off out of no where. I later found out I blew fuse #14 for the radio. I replaced the fuse and everything was fine until I hit a speed bump and the radio blew a fuse again.

What I've done so far:

So I've taken the radio out and replaced the wiring harness. I used to have LED lights crimped onto the purple? wires for the back right speaker, so I thought that having that big wad of wire may have undone the crimp and touched bare metal and short circuited. So I took out the LED lights and re-did the wiring harness back to normal and I'm still blowing fuse #14 for the radio when I go over bumps...

A) I've unhooked the subwoofer and tested to see if the sub was the issue, which it isn't. I still blow the fuse when hitting a bump.

B) The harness is crimped correctly and doesn't come into contact with bare metal.

C) The radio is an alpine cda-105, I have stock speakers in the dash, 3-way kickers in the rollcage, and a 10" active sub under my seat.

D) Do you think it could be the radio itself? I mean, the fuse in the back of the radio isn't blown because the radio wouldn't even turn on if it was blown.

E) I've researched and people say it could be a bad ground/hot wire malfunction. The only ground/hot wires I know of are on my battery, in the wiring harness for the radio, and the ground/hot wire for my sub.

Please help! All this troubleshooting is driving me insane

Tyler is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 03:14 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC