Help! Stereo Wiring Problem - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Tech Forums > Communications and Electronics

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-05-2010, 02:21 PM   #1
Jeeper
 
Join Date: Nov 2009
Location: Clemson
Posts: 73
Help! Stereo Wiring Problem

So I've installed a Pioneer head unit all the way, except the power won't turn on...My 07 JK has a black and a red power going to the harness that attached into the old radio. The adapter harness reciever from Crutchfield has yellow and black power leads (yellow constant power, black ground).

However, there is a wire from the pioneer radio that is red and it is for the ignition power. I don't know where to plug this wire into in order to get power...and suggestions? Thanks!

Always JK'n is offline   Quote Quick Reply
Old 01-05-2010, 02:55 PM   #2
Jeeper
 
Jaydogg25's Avatar
 
Join Date: Jun 2009
Location: Reynoldsburg, Ohio
Posts: 340
Send a message via AIM to Jaydogg25
for a radio to turn on you need all 3 wires, yellow (conatant, red (ignition), and black (ground) if any of them are unhooked radio will not power up.

now issue you could be having is your vehicle may have, whats known, as a can-bus wiring in it.. if so you need $130 harness, as a standard one wont work

thats probably why you dont see a red wire, alot of can-bus systems the vehicles computer controls when the radio turns on/off, along w/ other features for vehicle that may be ran through factory radio. for example GM's run air bag's , chimes, fuel economy etc etc through radio so trying to hard wire or use wrong harness isn't recomended as u could damage parts of vehicle and in some cases (w/ GM) could blow every airbag.

did a quick look up on Best Kits Online and they list a can-bus harness for your vehicle..the "normal" wire they list is missins alot of wires on it so i dont think it would work.


sorry for the bad news but it's not uncommon for any vehicle made in last 10y to be this way....just not same as good old $13 wire harnesses.
__________________
95 YJ, 4" suspension lift, 32's, 2.5l 4 cyl (350 built and waiting to be installed in spring, along with ford 8.8 rear end)
Jaydogg25 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
idle issue and wiring problem The89YJ YJ Tech Forum 8 10-16-2009 11:13 PM
gauges wiring problem upinar YJ Tech Forum 1 12-17-2007 12:05 AM
2008 Jeep Sahara - Aftermarket Stereo problem with factory amp Haloshot Communications and Electronics 0 11-27-2007 01:35 PM
TJ Error codes khenderson TJ Tech Forum 3 08-19-2005 12:36 AM


» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 09:07 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC