JK - Amp and Subwoofer - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Tech Forums > Communications and Electronics

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-13-2012, 01:45 PM   #1
Jeeper
 
nicolas-eric's Avatar
 
Join Date: Jan 2007
Location: Hamburg, Germany
Posts: 5,851
Send a message via ICQ to nicolas-eric Send a message via AIM to nicolas-eric Send a message via MSN to nicolas-eric Send a message via Yahoo to nicolas-eric
JK - Amp and Subwoofer

Hello.

Today I installed a 4 x 150W RMS amp and a 10" subwoofer in a homemade ported box in my GFs JK.

The stock front speakers are connected to channel 1+2 and the sub is connected to channel 3+4 (bridged).
The stock speakers in the roll bar are still connected to the radio.

It sounds so much better than before. And its very loud. Topless with 80 mph I can only hear the music and nothing else like the diesel engine or the tires.

Nicolas-Eric
Attached Thumbnails
Click image for larger version

Name:	image-3645083449.jpg
Views:	87
Size:	132.8 KB
ID:	104553   Click image for larger version

Name:	image-3296635253.jpg
Views:	81
Size:	138.3 KB
ID:	104554  


nicolas-eric is offline   Quote Quick Reply
Old 11-10-2012, 06:29 PM   #2
Jeeper
 
nicolas-eric's Avatar
 
Join Date: Jan 2007
Location: Hamburg, Germany
Posts: 5,851
Send a message via ICQ to nicolas-eric Send a message via AIM to nicolas-eric Send a message via MSN to nicolas-eric Send a message via Yahoo to nicolas-eric
Hello.

Some weeks ago I upgraded my GFs sound system.

I installed a new 12" ported subwoofer and a 4x 250w RMS amp.

Here are some pics:
Attached Thumbnails
Click image for larger version

Name:	image-3863730520.jpg
Views:	39
Size:	102.8 KB
ID:	177014   Click image for larger version

Name:	image-852153213.jpg
Views:	42
Size:	109.7 KB
ID:	177015  

Click image for larger version

Name:	image-1828813402.jpg
Views:	31
Size:	110.6 KB
ID:	177016   Click image for larger version

Name:	image-3095919238.jpg
Views:	37
Size:	98.2 KB
ID:	177017  

nicolas-eric is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Subwoofer Doom Swanktify2 Communications and Electronics 6 08-27-2013 06:35 PM
NV3550 noise and shifter feels loose CMA_Rider TJ General Discussion Forum 7 03-13-2012 07:33 PM
Code P0121 and Bucking, this isn't good. Need Help. burton160w TJ General Discussion Forum 3 03-13-2012 03:25 PM
Lift and wheels installation underway Charlie Ironman TJ General Discussion Forum 3 03-13-2012 12:16 PM
Wheels Adapters and Tires jroberd TJ General Discussion Forum 0 03-13-2012 09:36 AM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 06:29 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC