Kenwood 12" sub and Fosgate Amp - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-25-2012, 10:44 PM   #1
Jeeper
 
USMC0802's Avatar
 
Join Date: Mar 2012
Location: SW OK
Posts: 35
Kenwood 12" sub and Fosgate Amp

I bought 2 12" ken woods in enclosures and a 900 watt Fosgate amp from a buddy of mine and installed one sub and the amp today in my '05 X.

It sounds great, but I was wondering if anyone else is running this setup or has had experience with this equipment, I've only had it running for a couple hours, but tomorrow I'm looking forward to some thump.

Am I overlooking anything obvious? I've never installed an amp or sub before, so this was a learning experience for sure. Thanks!

__________________
"Live as brave men, and if fortune is adverse, front its blows with brave hearts."
-Marcus Tullius Cicero
USMC0802 is offline   Quote
Old 04-26-2012, 10:14 AM   #2
Jeeper
 
Jma20a's Avatar
 
Join Date: Apr 2007
Location: Fairfield, CT
Posts: 3,046
in the stickies there are instructions on how to set you gain.
Jma20a is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 10:48 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC