Need Help with Factory Sub - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Tech Forums > Communications and Electronics

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-15-2013, 09:00 AM   #1
Jeeper
 
Cdubu52's Avatar
 
Join Date: Jun 2010
Location: Pittsboro, NC
Posts: 89
Need Help with Factory Sub

I have an 04 TJ Sahara. I just swapped out the factory deck and front and sound pod speakers. My sub works, but sounds horrible.

What are my possible solutions? The first thing I am going to do is disconnect the sub. The problem is I was hoping to keep the sub in the center console due to size concerns. I dont want to build any kind of enclosure for the back and under this seat is not an option. I actually use the back area of my Jeep and I have a 7 year old, who rides in the back.

The new Deck that I installed is an Alpine CDE-HD137BT-CD. It is pretty sweet with Bluetooth phone and audio streaming.

I installed 4 Polk Audio DB 521's. The fronts mounted with Nalin brackets in the dash and the second pair is in the sound pods.

The problem is the Sub sounds like crap, beyond crap. Im not sure if its torn or blown out, but it sounds awful.

Any help is appreciated.

Cdubu52 is offline   Quote Quick Reply
Old 02-15-2013, 09:58 AM   #2
Jeeper
 
eboven's Avatar
 
Join Date: May 2012
Location: Black Hawk, CO
Posts: 643
Depending on how much you want to spend, my recommendation would be to get a Kicker 6.5" CompVT subwoofer and a small amp to drive it. With a little bit of plastic shaving, you can make the CompVT fit into the stock enclosure, then install the amp under the driver's dash or near the subowoofer enclosure if there is room.

You can pick the sub up for around $80 and a little Kicker 2-channel amp can be picked up for around $90

eboven is offline   Quote Quick Reply
Old 02-24-2013, 07:29 AM   #3
Jeeper
 
Rubiconlj's Avatar
 
Join Date: Feb 2012
Location: Gatesville, TX
Posts: 794
I would be interested if you tried this replacement speaker in the original enclosure. I recently had a new sub installed in the original enclosure in the console for the very same reasons as you and it still sounds like crap. I honestly think its the original enclosure that was made only for OEM speaker/amp combo. I'm lost as to what to do now. It sounds so bad I just want to disconnect the sub. Did you have any luck?
__________________
Tiffany
Rubiconlj is offline   Quote Quick Reply
Old 02-24-2013, 08:22 AM   #4
Jeeper
 
eboven's Avatar
 
Join Date: May 2012
Location: Black Hawk, CO
Posts: 643
Quote:
Originally Posted by Rubiconlj View Post
I would be interested if you tried this replacement speaker in the original enclosure. I recently had a new sub installed in the original enclosure in the console for the very same reasons as you and it still sounds like crap. I honestly think its the original enclosure that was made only for OEM speaker/amp combo. I'm lost as to what to do now. It sounds so bad I just want to disconnect the sub. Did you have any luck?
Are you still using the stock amp to drive the new sub in the console, or did they add in a new amp for it too? Any aftermarket sub will want much more power than the cheap factory setup can provide.
eboven is offline   Quote Quick Reply
Old 02-24-2013, 05:42 PM   #5
Jeeper
 
Rubiconlj's Avatar
 
Join Date: Feb 2012
Location: Gatesville, TX
Posts: 794
Quote:
Originally Posted by eboven

Are you still using the stock amp to drive the new sub in the console, or did they add in a new amp for it too? Any aftermarket sub will want much more power than the cheap factory setup can provide.
No, he installed a new 350w amp under the dash. I love the sound all the spreakers make and even the low end tones I get from some songs. It's just most songs have a fast bass beat and it sounds like a dink instead of a thump. I don't know much about boxes, but to me it just seems like that OEM box with the new sub.
__________________
Tiffany
Rubiconlj is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 10:27 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC