Power Distribution - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Tech Forums > Communications and Electronics

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-02-2012, 12:34 PM   #1
Jeeper
 
BigThunder's Avatar
 
Join Date: Nov 2011
Posts: 125
Power Distribution

Need a little help here, as this is not making sense to me.

I just completed this on my YJ: 12V Aux Fuseblock

I first ran the jumper to the power/fused block from the battery, with all the grounds still at the common site (battery). All accessories worked with no issue, so I know I have power.

I then moved all of my negatives to the terminal bar with the bar grounded to the firewall (other items grounded there as well). Nothing worked. I then took my grounding wire from the firewall and moved it to the negative battery terminal ~ nothing.

What am I missing with my ground? All of my connections are tight (checked and double checked). All fuses are good (checked and double checked). All connections to the relay(s) are also good.

What am I missing??

BigThunder is offline   Quote Quick Reply
Old 01-02-2012, 12:52 PM   #2
Jeeper
 
whiteyj's Avatar
 
Join Date: Jul 2005
Location: Pleasanton CA
Posts: 4,856
Sure you're really getting power to the block rather than a ground issue?

__________________
Fallen Angel...Former MOD
whiteyj is offline   Quote Quick Reply
Old 01-02-2012, 12:56 PM   #3
Jeeper
 
BigThunder's Avatar
 
Join Date: Nov 2011
Posts: 125
If I reconnect all the grounds back to the battery, all accessories work with out issue.
BigThunder is offline   Quote Quick Reply
Old 01-02-2012, 03:57 PM   #4
Jeeper
 
Join Date: Dec 2011
Posts: 605
Check continuity on the terminals of the ground bar with nothing hooked up. Make sure the ground bar is good. Then hook up the ground to the firewall and check for 12v from the terminals to the battery+
I-Want-A-Jeep is online now   Quote Quick Reply
Old 01-02-2012, 05:11 PM   #5
Jeeper
 
BigThunder's Avatar
 
Join Date: Nov 2011
Posts: 125
Quote:
Originally Posted by I-Want-A-Jeep View Post
Check continuity on the terminals of the ground bar with nothing hooked up. Make sure the ground bar is good. Then hook up the ground to the firewall and check for 12v from the terminals to the battery+
I went through a total of three terminal bars, and never could get the continuity. Now, the grounds are back where they were destined to be ~ the negative battery post

I had to tap out for now.
BigThunder is offline   Quote Quick Reply
Old 01-02-2012, 05:47 PM   #6
Jeeper
 
Join Date: Dec 2011
Posts: 605
Did you check the ground bar with a multimeter? Maybe it's not made to be a buss bar, rather just a seperate connection for each terminal??
I-Want-A-Jeep is online now   Quote Quick Reply
Old 01-02-2012, 06:18 PM   #7
Jeeper
 
BigThunder's Avatar
 
Join Date: Nov 2011
Posts: 125
Quote:
Originally Posted by I-Want-A-Jeep View Post
Did you check the ground bar with a multimeter? Maybe it's not made to be a buss bar, rather just a seperate connection for each terminal??
I did check it with a multi meter. I had continuity only on the terminal where it was grounded to the firewall or battery (all three bars). I don't know whether or not it was designed to be a buss bar (lack of my knowledge), but it was the same terminal bar that is in the attached link.
BigThunder is offline   Quote Quick Reply
Old 01-02-2012, 06:29 PM   #8
Jeeper
 
Join Date: Dec 2011
Posts: 605
Well that bar is definitely the problem. For some reason that bar doesn't connect from terminal to terminal. Have any pictures or model numbers from your bar?
I-Want-A-Jeep is online now   Quote Quick Reply
Old 01-02-2012, 06:41 PM   #9
Jeeper
 
BigThunder's Avatar
 
Join Date: Nov 2011
Posts: 125
BigThunder is offline   Quote Quick Reply
Old 01-02-2012, 06:52 PM   #10
Jeeper
 
whiteyj's Avatar
 
Join Date: Jul 2005
Location: Pleasanton CA
Posts: 4,856
Barrier strip is not ganged together. You need the jumper strip on the bottom of the page (in your link) to gang all your neg's together. Can't even begin to explain why it might work at all in either of the config's you mentioned.

__________________
Fallen Angel...Former MOD
whiteyj is offline   Quote Quick Reply
Old 01-02-2012, 06:57 PM   #11
Jeeper
 
BigThunder's Avatar
 
Join Date: Nov 2011
Posts: 125
I took one of them apart ~ on one side there is a strip (possibly copper) that connects all the terminals on one side together. That seems to fit the bill (at least to me) for ganging them all together. Hell, I don't know, that's why I'm asking.
BigThunder is offline   Quote Quick Reply
Old 01-02-2012, 07:33 PM   #12
Jeeper
 
Join Date: Dec 2011
Posts: 605
Either way, if you don't get continuity from one terminal to another it's not the right kind of bar.

You need a ground block/buss bar/distribution bar/junction bar/ etc. Like this:
Stud Junction Block

I-Want-A-Jeep is online now   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Loosing power to radio, cig lighter, and turn ksplayland YJ Tech Forum 4 02-11-2012 05:11 PM
Speakers Thump when power is turned off. danford1 Communications and Electronics 0 12-30-2010 01:05 PM
Power loss when wet ISUSteve YJ Tech Forum 6 12-27-2010 03:17 PM
Loss of Power GavinDubai YJ Tech Forum 6 12-26-2010 11:07 PM
power distribution box NAVYCHIEF YJ Tech Forum 0 12-21-2010 11:19 AM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 09:44 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC