Radio(s) not working - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-03-2012, 05:51 PM   #1
Jeeper
 
WarBoomer's Avatar
 
Join Date: Jul 2010
Location: Bham, AL
Posts: 268
Radio(s) not working

I have an 05. I had replaced the factory radio with a sony (I know, I know). It has worked no problems for 2 years. Recently I added a 4ch Polk Audio amp and infinity speakers all around.

2 days ago I hit a pot hole in the city and the radio just stopped working. Worked on it, checked the power and ground (Red and black) and I was getting 12V.

So I assumed the radio was just cooked. Went and bought a cheap pioneer to replace it. Took time to solder and shrink tube the harness, plug it in aaaaaaaand.....nothing. So, I clipped the red and black wires, checked for power and ground, still good. Re-soldered the wires, and plugged in again....still nothing.

So at this point I'm mad. I go to the attic and dig out the factory radio. Plug it in....nothing. All fuses are good (even swapped the 10 for the radio just for good measure). I assumed if I had good power and good ground that's all it would take for the radio to at least turn the screen on......

Any radio guru's out there that might have some tricks? I have no idea what else to check.

__________________
"The male body is utilitarian. It's for getting around. It's like a Jeep" - Elaine Benes.
WarBoomer is offline   Quote Quick Reply
Old 06-03-2012, 05:53 PM   #2
Sponsoring Vendor
 
Ibuildembig's Avatar
 
Join Date: Aug 2010
Location: Fruitland, Missouri
Posts: 8,351
You know that you have to use the yellow wire too right? It goes to constant 12 volt power.

Ibuildembig is offline   Quote Quick Reply
Old 06-03-2012, 06:15 PM   #3
Jeeper
 
WarBoomer's Avatar
 
Join Date: Jul 2010
Location: Bham, AL
Posts: 268
Yellows hooked to yellow... Red is hooked to red. I didnt test the yellow. Guess thats next
__________________
"The male body is utilitarian. It's for getting around. It's like a Jeep" - Elaine Benes.
WarBoomer is offline   Quote Quick Reply
Old 06-03-2012, 07:06 PM   #4
Jeeper
 
WarBoomer's Avatar
 
Join Date: Jul 2010
Location: Bham, AL
Posts: 268
Bingo. 15A fuse under the hood blown. Was getting no power from yellow. Thanks for the help!
__________________
"The male body is utilitarian. It's for getting around. It's like a Jeep" - Elaine Benes.
WarBoomer is offline   Quote Quick Reply
Old 06-03-2012, 07:10 PM   #5
Jeeper
 
InvertChaos's Avatar
 
Join Date: Sep 2010
Location: NoVa
Posts: 7,879
Easy fix!
__________________
|2004 Jeep TJ "Green Machine"|4.0L 5 speed Dana44|33x12.50x15 Goodyear Duratracs|2.5" RC coils + 1.25" body lift|OME NitroSport shocks|4.56 gears|Skid Row Engine Skid|BCC Sliders|Currie AntiRock|
InvertChaos is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 07:08 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC