Radio signal issue - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-28-2010, 05:55 PM   #1
Jeeper
 
Billytehbob's Avatar
 
Join Date: Aug 2010
Location: Irmo, SC
Posts: 84
Radio signal issue

Hey guys, I was hoping somebody might have an answer to my question, so here goes. I'm having issues with radio signal on FM and AM stations being pretty weak aside from a country station. I thought it might be an issue with my radio or antenna cable, but if I place my hand on the mast, the stations come in loud and clear. My radio is a Sony xplod which apparently sucks in cars, but that wouldnt seem to hold much merit to my problem.

Thanks

__________________
'99 Four-banger
Wants meaner tires
Billytehbob is offline   Quote
Old 11-28-2010, 10:04 PM   #2
J10
Jeeper
 
J10's Avatar
 
Join Date: Oct 2010
Posts: 210
When I first got my jeep I had the same issue and it was that the cable was pulled partially out. It runs behind the glove box and is pretty short consequently easy to get pulled out a litttle. I'd give that a look.

J10 is offline   Quote
Old 11-28-2010, 11:31 PM   #3
Jeeper
 
Billytehbob's Avatar
 
Join Date: Aug 2010
Location: Irmo, SC
Posts: 84
It's plugged in all the way into the back of the radio, but I haven't been able to thoroughly check the connection at the mast, but this still wouldn't seem to explain why holding the antenna fixes the issues, unless my body acts like an amplifier.
__________________
'99 Four-banger
Wants meaner tires
Billytehbob is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio issue 2010 NavSatHdd Darst JK General Discussion Forum 10 01-04-2014 02:58 PM
push button switch installed - Now Radio Issue steve o TJ Tech Forum 0 05-13-2010 10:15 PM
Turn Signal Grounding issue? MrMiyagi TJ Tech Forum 1 09-15-2009 05:26 PM
Turn signal interfering with the radio ? BARKDOG67 TJ Tech Forum 3 05-14-2009 12:35 PM
turn signal / radio problem nomik4u TJ Tech Forum 5 12-20-2008 12:55 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 10:27 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC