Turn Signal Flasher - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-09-2011, 10:41 AM   #1
Newb
 
Join Date: Feb 2011
Posts: 3
Turn Signal Flasher

Jeep Wrangler Sport 1997 - My Hazard lights and both turn signals are not working. I was going to change the turn signal flasher but I'm not sure where it is located. Any ideas?

mjbrennan77 is offline   Quote
Old 02-09-2011, 10:49 AM   #2
Jeeper
 
Vroooom's Avatar
 
Join Date: Jun 2010
Location: Sin-Tex
Posts: 1,715
It's INSIDE the steering column. Grrrr....

I've read here that its not too difficult to disassemble the column clam-shell to get to it.

But I've been too lazy to try it myself. I replaced my tail-lights with LED units and now have a "hyperactive flasher".

Someday....when its gets back above frigid (70) I might give it a shot.

__________________
Threads wander aimlessly....always refer back to post #1
2012 Black Unlimited Sahara (mine)
2011 Black Corvette 3LT (wife's)
2005 Black Suzuki C50T (ours)
"Hope" is NOT a strategy
Vroooom is offline   Quote
Old 02-22-2011, 10:55 AM   #3
Jeeper
 
PolloLoco's Avatar
 
Join Date: Feb 2011
Location: DeRidder, LA
Posts: 53
I had the same problem too on my 97 TJ but it turned out to be the turn signal switch. About $70 from Schucks fixed it. My brake lights didn't work either, have you checked to make sure that they are still lighting up?
__________________
97 TJ, 4.7L Stroker, 4.88 Ford 8.8 w/Auburn ECTED, HP30 w/ARB Air Locker, AX-15, NP231 w/Rugged Ridge SYE, 33x10.50 BFG A/T, 4" Skyjacker, 1.25" body lift, 1" MORE motor mounts, Kilby fuel tank skid, UCF ultra-high clearance 1/4" steel skid, HMMWV-style snorkel, 63mm TB
PolloLoco is offline   Quote
Old 02-26-2011, 08:07 AM   #4
Newb
 
Join Date: Feb 2011
Posts: 7
I have the same problem and I swapped in a new turn signal switch myself, $40 for the part at Autozone. It didn't fix the problem though and now I'm blowing fuses, I could've gotten a bad switch and/or could be a relay. I'm planning on going back today to use the warranty on the switch, get a new relay and replace the bulbs all around. It's a 2000 with 227k miles on it, so they're probably due anyways and the bulbs are cheap. If all that doesn't fix it, then I don't know what the hell is wrong.

It isn't hard to replace the switch, the top half of the column is a pain, but I've had it off twice now. You'll also need to remove the IP cowl and the panel below column to get at everything. You'll need a #2 phillips and a Torx set, but I think it was only something like 8 screws to deal with.
sdmangan is offline   Quote
Old 02-26-2011, 03:38 PM   #5
Newb
 
Join Date: Feb 2011
Posts: 7
Well, I found my problem and I've got my fog, IP, & tail lights back. Turned out to be a corroded driver's side front turn signal bulb socket. The flasher relay I bought turned out to be the wrong one although Autozone's website says otherwise. And, as I've read on other posts, the socket isn't available in store. The only one offered online requires cutting wires even though the socket is a connector. So off to the salvage yard I'll go.
sdmangan is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn Signal Problem** Johntom TJ Tech Forum 2 11-16-2014 01:23 PM
Almost Ticketed For NOT Signaling A Left Turn! Blackbeard1718 JK General Discussion Forum 57 10-01-2010 11:42 PM
Turn Signal Flasher Problem? chilisteve TJ Tech Forum 13 08-10-2010 06:39 AM
Turn signal problem gtguyonli TJ Tech Forum 7 07-06-2010 10:55 PM
Turn Signal Grounding issue? MrMiyagi TJ Tech Forum 1 09-15-2009 05:26 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 03:03 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC