dead jeep. - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > NorthEast Regional Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-12-2012, 12:36 PM   #1
Jeeper
 
mattmason's Avatar
 
Join Date: Apr 2012
Location: Lakeville Mass.
Posts: 59
Images: 14
Send a message via Yahoo to mattmason
dead jeep.

Ok the starter, and starter switch sylonoid went out on me the funny part to me is also with those two things out nothing turns on all my gages don't come on nor anything else when the key is turned the lights and hazard don't work. I am going threw this jeeps issues I am planning on replacing all fuses and all parts to include the ignition switch as well as the starter and sylonoid as well I could use any advice that's out there.

__________________
89YJ Sahara (giant pain in my ass)
mattmason is offline   Quote Quick Reply
Old 10-27-2012, 01:23 PM   #2
Jeeper
 
Join Date: Feb 2012
Location: Atco, NJ
Posts: 58
What year,
what model
How old are you
What are you wearing

OK, skip the last one, but more info is needed.

Is the battery installed backwards?

dennis461 is offline   Quote Quick Reply
Old 02-26-2013, 01:02 PM   #3
Jeeper
 
mattmason's Avatar
 
Join Date: Apr 2012
Location: Lakeville Mass.
Posts: 59
Images: 14
Send a message via Yahoo to mattmason
its a 1989 sahara, but heres what i have done as of so far. starter, starter relay battery, fuses, fuel pump, carb, fuel pump relay, ignition coil, replaced. it came back to life for a bit but it was snowing so i only got it up to 30mph and brought it home as my top has some issues... well i was going to take it to work the next morning but it started up and as soon as i hit the headlight switch everything died just like before...
yes i am new to the jeep thing and it is a learning process
__________________
89YJ Sahara (giant pain in my ass)
mattmason is offline   Quote Quick Reply
Old 02-26-2013, 01:25 PM   #4
Jeeper
 
chuckuga's Avatar
 
Join Date: Jul 2012
Location: Sarasota fl
Posts: 33
Check your fuses again.
chuckuga is offline   Quote Quick Reply
Old 03-10-2013, 09:11 AM   #5
Jeeper
 
mattmason's Avatar
 
Join Date: Apr 2012
Location: Lakeville Mass.
Posts: 59
Images: 14
Send a message via Yahoo to mattmason
checked the fuses they are all good. now i am still woring on that switch. holy crap its a pain in the ass to get to its like they decided to put it in the worst possible place to get up into
__________________
89YJ Sahara (giant pain in my ass)
mattmason is offline   Quote Quick Reply
Old 03-10-2013, 11:55 AM   #6
Newb
 
Join Date: Mar 2013
Posts: 4
Check the wire harness above the parking brake release lever. Mine had worn through and caused a similar problem. It needed hung so it wasn't rubbing the lever and the harness retaped so it stopped rubbing an exposed wire.
892586cyl is offline   Quote Quick Reply
Old 03-18-2013, 09:56 PM   #7
Jeeper
 
mattmason's Avatar
 
Join Date: Apr 2012
Location: Lakeville Mass.
Posts: 59
Images: 14
Send a message via Yahoo to mattmason
sounds like something i will have to look into. besides im at a stand still with the dash and ac pulled apart. started digging in to see if i could get the ignition switch replaced and turns out the mounting bracket for the one i bought is bacwards then the kids broke my head lamp so yea on the SOL for the time being. honestly wish i had a machanic buddy here in mass that knew this stuff inside and out, but being new up here i dont get that luxury
__________________
89YJ Sahara (giant pain in my ass)
mattmason is offline   Quote Quick Reply
Old 04-04-2013, 08:26 AM   #8
Jeeper
 
mattmason's Avatar
 
Join Date: Apr 2012
Location: Lakeville Mass.
Posts: 59
Images: 14
Send a message via Yahoo to mattmason
at the point where i am looking into the fusable link to the starter. as it is a main contact point for juice to get to the jeep. (this must be what i get for not naming this one.)
__________________
89YJ Sahara (giant pain in my ass)
mattmason is offline   Quote Quick Reply
Old 04-04-2013, 08:27 AM   #9
Jeeper
 
mattmason's Avatar
 
Join Date: Apr 2012
Location: Lakeville Mass.
Posts: 59
Images: 14
Send a message via Yahoo to mattmason
totally honest i want it running as i am hoping to misapropriate some funds from my unit to hold an event some time this summer.

__________________
89YJ Sahara (giant pain in my ass)
mattmason is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:49 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC