temp sending unit - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > NorthEast Regional Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-28-2010, 12:03 PM   #1
Jeeper
 
wrangler yj's Avatar
 
Join Date: Jul 2010
Location: Boston
Posts: 53
temp sending unit

Hi I have a 92 wrangler yj with a 4.0 litre straight 6 and the temp sending unit will not work when i turn it on the needle goes to 100 degrees but will no move past that i replaced the temp sensor but it didn't do it i also have a problem with my oil pressure gauge it usually works but it has been randomly going crazy showing different pressures then working again if any one could help me with my problems i would appreciate it thanks.

wrangler yj is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil pressure sending unit? am i screwed? AtcoTrailsINC TJ Tech Forum 11 03-15-2010 04:54 AM
new head gasket and sending unit..still have oil pressure gauge issue TXST8tj TJ General Discussion Forum 10 09-18-2008 11:37 AM
Broken Temp sending unit in intake RWOOD TJ Tech Forum 2 08-14-2007 10:15 AM
wtb sending unit and or fuel pump scooter18155 Classifieds Archive 4 01-03-2007 04:20 PM
Where is the water temp sending unit? theorrminator YJ General Discussion Forum 2 04-23-2006 04:56 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 09:33 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC