4x4 Instaltion shop in Austin? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > Texas Jeep Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-17-2012, 08:02 PM   #1
Newb
 
Join Date: Oct 2012
Location: Austin
Posts: 14
4x4 Instaltion shop in Austin?

All, I am in hopes to get my wife a 2013 JKU for Christmas. She has always wanted an old Jeep for the family to mess around in, but for reasons I want to get her a new one that has been costumized to her style. I don't have the ability to do the work myself so I need a good shop in the Austin area to do the work.

Things I need done will be adding a lift, tires, rims, hood, paint, and etc.....

Thanks again for any recommendation......

Marlinman is offline   Quote
Old 10-18-2012, 07:04 AM   #2
Supporting Member

WF Supporting Member
 
jeepers29's Avatar
 
Join Date: Feb 2011
Location: Georgetown, Texas
Posts: 3,751
Welcome to the forum! You can try Just Jeeps, think they are in Round Rock. There is also Jeep Masters down on S. Congress. I don't have experience with either but you could google reviews. Sounds like your wife is a Keeper. LOL

jeepers29 is offline   Quote
Old 10-18-2012, 12:35 PM   #3
Jeeper
 
CubbyXL7's Avatar
 
Join Date: Apr 2011
Location: Central Texas
Posts: 313
MarlinMan - if you are in Round Rock, then I recommend Jerry's Garage at AW Grimes and Old Settler's. The owner's son and the shop manager are both jeepers. They have mine in the shop right now doing an engine swap. Not necessarily the cheapest around, but definitely quality work.

On another note - are you the same MarlinMan I have seen on the Marlinowners forum?
CubbyXL7 is offline   Quote
Old 10-18-2012, 07:43 PM   #4
Supporting Member

WF Supporting Member
 
jeepers29's Avatar
 
Join Date: Feb 2011
Location: Georgetown, Texas
Posts: 3,751
Cubby, what happened to your engine? It seemed to be running fine when I met you in that parking lot a few weeks ago?
jeepers29 is offline   Quote
Old 10-18-2012, 11:25 PM   #5
Jeeper
 
CubbyXL7's Avatar
 
Join Date: Apr 2011
Location: Central Texas
Posts: 313
Cracked block in the water jacket. Had a slow coolant leak. I thought it was the head gasket. Pulled the head and the gasket was good. Had the head machined (it was warped) and put it back on, and it ran great, but the coolant leak was still there. Had about three of four cracks in the block on the driver's side.

Bought a 4.2 crate motor from a place in Houston and Jerry's is doing the install. Almost done, but all kinds of good thing happened like
- replaced the clutch while it was out
- Exhaust manifold was warped and had to replace that
- had to replace the distributor

They got it running this evening (I was there) and it sounded great. Have to resolve a few vacuum line issues, and I should have her back tomorrow afternoon.

After some break in, I will be ready to hit the trails again soon.
CubbyXL7 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 03:33 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC