eletrical help - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > California Jeep Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-09-2013, 08:06 PM   #1
Jeeper
 
castman2's Avatar
 
Join Date: Aug 2012
Location: Valencia
Posts: 93
eletrical help

Need some ideas on what may be wrong with my yj. Driving down the road and lost all elctrical. Can't really look at it right now as I am sitting.g on the side of a busy road in work clothes waiting on a tow.

castman2 is offline   Quote
Old 05-09-2013, 08:55 PM   #2
Jeeper
 
WOKNROX's Avatar
 
Join Date: Oct 2012
Location: SoCal Hi Dez
Posts: 4,208
Well..if it was running and just shutdown ....and Im thinking there is no sign of power...I'd look at the main power fuse/breaker under the hood and if that checks out okay...then turn ur attention to the bulkhead plug/connection on the firewall right below the break master cylinder ...a comin problem with the early Yj's and Cj's ....
Hope this helps.

__________________


WOKNROX!
Let's go wheelin!™
WOKNROX is offline   Quote
Old 05-09-2013, 09:05 PM   #3
Jeeper
 
Radioman's Avatar
 
Join Date: Dec 2011
Location: Roseville, CA
Posts: 133
The problem might be more basic. I would start by checking for clean and tight connections at the battery posts and at the ends of the positve and negative power cables.

If the cable and posts are good along with the fuses mentioned in the above post, provide additional information on the power loss.
Radioman is offline   Quote
Old 05-09-2013, 09:14 PM   #4
Jeeper
 
WOKNROX's Avatar
 
Join Date: Oct 2012
Location: SoCal Hi Dez
Posts: 4,208
If the battery took a bump it would continue to run off the alternator and if the alternator died ...it would continue to run on the battery ...but of course ..it never herts to look it over..
__________________


WOKNROX!
Let's go wheelin!™
WOKNROX is offline   Quote
Old 05-09-2013, 09:52 PM   #5
Jeeper
 
castman2's Avatar
 
Join Date: Aug 2012
Location: Valencia
Posts: 93
Well I got it running. Bad fuse. Hey y'all thanks for the help.
castman2 is offline   Quote
Old 05-09-2013, 09:55 PM   #6
Jeeper
 
WOKNROX's Avatar
 
Join Date: Oct 2012
Location: SoCal Hi Dez
Posts: 4,208
No problem ...glad you got the ol boy runnin again ...make sure to carry extra fuses ...
Hopefully its not an early sign of a pesky Gremlin ...
__________________


WOKNROX!
Let's go wheelin!™
WOKNROX is offline   Quote
Old 05-09-2013, 10:10 PM   #7
Jeeper
 
castman2's Avatar
 
Join Date: Aug 2012
Location: Valencia
Posts: 93
For sure. This old things does what I want but it has its quirks. Don't need to add gremlins to the mix. I saw the movie and that didnt go well :-)
castman2 is offline   Quote
Old 05-09-2013, 10:15 PM   #8
Jeeper
 
WOKNROX's Avatar
 
Join Date: Oct 2012
Location: SoCal Hi Dez
Posts: 4,208
Quote:
Originally Posted by castman2 View Post
For sure. This old things does what I want but it has its quirks. Don't need to add gremlins to the mix. I saw the movie and that didnt go well :-)
He he..you funny guy...
Put dielectric grease on all your electrical conditions ...that'll help big time..
hopefully we'll see you Saturday ..
__________________


WOKNROX!
Let's go wheelin!™
WOKNROX is offline   Quote
Old 05-09-2013, 10:33 PM   #9
Jeeper
 
castman2's Avatar
 
Join Date: Aug 2012
Location: Valencia
Posts: 93
God willing and the creek don't rise and the gremlins stay away. I should be there

castman2 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 07:32 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC