My jeep stalled - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > California Jeep Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-19-2014, 12:17 PM   #1
Jeeper
 
ELMOSYJ's Avatar
 
Join Date: Oct 2012
Posts: 1,631
My jeep stalled

So yesterday while at Joshua tree pepper stalled a few times. I noticed she was running a little hot but would turn on when it cooled off. Im thinking of getting a hood louvers and a 3 row radiator or just go with electric fan. The temperature under that hood was very high and even the frame was hot. What to do

__________________
ITS ELMO, AKA GAMA
ELMOSYJ is offline   Quote
Old 01-19-2014, 02:23 PM   #2
Jeeper
 
XJ_Phil's Avatar
 
Join Date: Nov 2012
Location: High Desert - CA
Posts: 1,338
Quote:
Originally Posted by ELMOSYJ View Post
So yesterday while at Joshua tree pepper stalled a few times. I noticed she was running a little hot but would turn on when it cooled off. Im thinking of getting a hood louvers and a 3 row radiator or just go with electric fan. The temperature under that hood was very high and even the frame was hot. What to do

Of everything you said you were going to do, probably any one of them will help resolve the problem. If you do them all, you should NEVER overheat again.

XJ_Phil is offline   Quote
Old 01-19-2014, 02:30 PM   #3
Jeeper
 
XJ_Phil's Avatar
 
Join Date: Nov 2012
Location: High Desert - CA
Posts: 1,338
Let me share one more little piece of wisdom, stay away from "Fail Safe" thermostats. I had 2 of them trip from bouncing around on the trail. Regular ones don't do that. Just what happened to me......ya know what I mean?
XJ_Phil is offline   Quote
Old 01-19-2014, 02:33 PM   #4
Jeeper
 
ELMOSYJ's Avatar
 
Join Date: Oct 2012
Posts: 1,631
Quote:
Originally Posted by XJ_Phil View Post
Let me share one more little piece of wisdom, stay away from "Fail Safe" thermostats. I had 2 of them trip from bouncing around on the trail. Regular ones don't do that. Just what happened to me......ya know what I mean?
that happened to mini
__________________
ITS ELMO, AKA GAMA
ELMOSYJ is offline   Quote
Old 01-19-2014, 04:13 PM   #5
Jeeper
 
WOKNROX's Avatar
 
Join Date: Oct 2012
Location: SoCal Hi Dez
Posts: 3,962
When it comes to thermostats I use the coolest temp I can get and drill an 1/8" hole in the flange.
I don't mess with fail safe thermos...
__________________


WOKNROX!
Let's go wheelin!™
WOKNROX is offline   Quote
Old 01-19-2014, 06:10 PM   #6
Jeeper
 
minisaba's Avatar
 
Join Date: Jul 2011
Location: So Cal
Posts: 843
Images: 3
Why not in the failsafe?
__________________
□||||||□
O--○-O
Misfits 4WD
minisaba is offline   Quote
Old 01-19-2014, 06:19 PM   #7
Jeeper
 
WOKNROX's Avatar
 
Join Date: Oct 2012
Location: SoCal Hi Dez
Posts: 3,962
Quote:
Originally Posted by minisaba View Post
Why not in the failsafe?
You can if you'd like...I just don't mess with then.
__________________


WOKNROX!
Let's go wheelin!™
WOKNROX is offline   Quote
Old 01-19-2014, 06:43 PM   #8
Jeeper
 
minisaba's Avatar
 
Join Date: Jul 2011
Location: So Cal
Posts: 843
Images: 3
Oh, I thought because of a particular reason. Does a 1/8 hole allow the coolant to mantain engine temperature?
__________________
□||||||□
O--○-O
Misfits 4WD
minisaba is offline   Quote
Old 01-19-2014, 06:51 PM   #9
Jeeper
 
WOKNROX's Avatar
 
Join Date: Oct 2012
Location: SoCal Hi Dez
Posts: 3,962
Yeah no real reason. But yes it will still maintain proper temps but if there is a problem you know coolant can still pass. Its just an old trick that's been passed down to me.
Kinda like black pepper in a leaky radiator...
__________________


WOKNROX!
Let's go wheelin!™
WOKNROX is offline   Quote
Old 01-19-2014, 06:52 PM   #10
Jeeper
 
WOKNROX's Avatar
 
Join Date: Oct 2012
Location: SoCal Hi Dez
Posts: 3,962
Hopefully you'll get that overheating problem in check before it gets really hot
__________________


WOKNROX!
Let's go wheelin!™
WOKNROX is offline   Quote
Old 01-19-2014, 07:04 PM   #11
Jeeper
 
XJ_Phil's Avatar
 
Join Date: Nov 2012
Location: High Desert - CA
Posts: 1,338
Fail Safe thermostat's will go into the "open" position if or when they go bad. It is a good idea in theory, but they can (and often do) open even when they shouldn't. That is much like running no thermostat at all. The plan is that your engine won't overheat when a failure occurs, but a stiff bump (like rock crawling) will cause them to open even before a problem happens. They cost a little more, and are probably good in some applications, but have no business in a Jeep if you plan to do much bouncing around off road. Just my opinion.
XJ_Phil is offline   Quote
Old 01-20-2014, 09:08 AM   #12
Jeeper
 
ELMOSYJ's Avatar
 
Join Date: Oct 2012
Posts: 1,631
My stupid tachometer dont work ugh
__________________
ITS ELMO, AKA GAMA
ELMOSYJ is offline   Quote
Old 01-21-2014, 06:49 AM   #13
DaK
Jeeper
 
Join Date: Feb 2012
Location: Lancaster, CA
Posts: 1,414
Have you been out mudding recently? If you have wash out your radiator fins. Had a guy a while back whose Jeep was doing the same thing and turned out he had a clogged up (mud impacted) radiator.

Other than that, sounds as though your thermostat could be acting up.
DaK is online now   Quote
Old 01-21-2014, 08:13 AM   #14
Jeeper
 
jeeperdave49's Avatar
 
Join Date: Sep 2012
Location: tehachapi
Posts: 99
Quote:
Originally Posted by minisaba View Post
Oh, I thought because of a particular reason. Does a 1/8 hole allow the coolant to mantain engine temperature?
The hole helps burp the system, releasing trapped air.
jeeperdave49 is online now   Quote
Old 01-22-2014, 05:26 PM   #15
Jeeper
 
ELMOSYJ's Avatar
 
Join Date: Oct 2012
Posts: 1,631
Plugged in the code reader in my jeep. The code i got was 45



Click image for larger version

Name:	image-3369674803.jpg
Views:	30
Size:	153.5 KB
ID:	692569
__________________
ITS ELMO, AKA GAMA
ELMOSYJ is offline   Quote
Old 01-22-2014, 06:59 PM   #16
Jeeper
 
WOKNROX's Avatar
 
Join Date: Oct 2012
Location: SoCal Hi Dez
Posts: 3,962
There you go...when we talked I suggested to you that you might want to look at that.
WOKNROX is offline   Quote
Old 01-22-2014, 07:38 PM   #17
Jeeper
 
ELMOSYJ's Avatar
 
Join Date: Oct 2012
Posts: 1,631
Quote:
Originally Posted by WOKNROX View Post
There you go...when we talked I suggested to you that you might want to look at that.
so i just replace or u think something else is causing it ?
__________________
ITS ELMO, AKA GAMA
ELMOSYJ is offline   Quote
Old 01-23-2014, 04:30 PM   #18
Supporting Member

WF Supporting Member
 
Gunner's Avatar
 
Join Date: Jun 2012
Location: Seal Beach
Posts: 7,889
Since your engine got hot and stalled then would not start till it cooled down a bit, I would think you have an overly rich/lean condition. I would look for a vacuum leak first then check for a plugged air filter. It did not do that before did it. I don't remember pepper having an overheat problem so my guess is something made it get hot. And the Idea of washing out the radiator fins is a good idea if you went to Azuza.
Gunner is offline   Quote
Old 01-23-2014, 04:57 PM   #19
Jeeper
 
ELMOSYJ's Avatar
 
Join Date: Oct 2012
Posts: 1,631
Quote:
Originally Posted by Gunner View Post
Since your engine got hot and stalled then would not start till it cooled down a bit, I would think you have an overly rich/lean condition. I would look for a vacuum leak first then check for a plugged air filter. It did not do that before did it. I don't remember pepper having an overheat problem so my guess is something made it get hot. And the Idea of washing out the radiator fins is a good idea if you went to Azuza.
i didnt go to Azusa mini did. It didnt over heat it just got to 210 or 215
__________________
ITS ELMO, AKA GAMA
ELMOSYJ is offline   Quote
Old 01-27-2014, 05:03 PM   #20
Jeeper
 
ELMOSYJ's Avatar
 
Join Date: Oct 2012
Posts: 1,631
My 02 sensor should be here soon
__________________
ITS ELMO, AKA GAMA
ELMOSYJ is offline   Quote
Old 01-29-2014, 08:21 PM   #21
Jeeper
 
ELMOSYJ's Avatar
 
Join Date: Oct 2012
Posts: 1,631
Got my 02 sensor today wohoooo

__________________
ITS ELMO, AKA GAMA
ELMOSYJ is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 07:05 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC