Copper Cache @ Nelsons - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > Nevada Jeep Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-04-2014, 10:59 PM   #1
Jeeper
 
stillcrazydave's Avatar
 
Join Date: Oct 2012
Location: Henderson NV
Posts: 235
Copper Cache @ Nelsons

Meet up 7am at Shell Station 95 and Wagon Wheel. Quick short trip befor kids soccer game at 1130

__________________
2012 JKU True Blue Oscar Mike
Rock Krawler 3.5 X-Factor
Black Rock Viper 35x12.5x15 MTR Kevlars
Evo Rock Skins
3.73 gears Limited Slip
stillcrazydave is offline   Quote
Old 04-05-2014, 12:01 AM   #2
Jeeper
 
Join Date: Mar 2014
Posts: 23
I just noticed that the c-clip was broken on one of my johnny joints. I have to replace that tomorrow, or I would be there.

I would love to get another ride in with you guys. I hope after this that the Jeep will be all set.

advjeeper is offline   Quote
Old 04-05-2014, 12:07 AM   #3
Jeeper
 
stillcrazydave's Avatar
 
Join Date: Oct 2012
Location: Henderson NV
Posts: 235
How's everything else on your rig doing? Was that what you heard last weekend? Got my Skids installed this week and took it to Adams today to get her measured for a new front driveline. Mines shot. Lasted longer than I thought. They said come back Monday to pick up the new driveline.
__________________
2012 JKU True Blue Oscar Mike
Rock Krawler 3.5 X-Factor
Black Rock Viper 35x12.5x15 MTR Kevlars
Evo Rock Skins
3.73 gears Limited Slip
stillcrazydave is offline   Quote
Old 04-05-2014, 12:57 AM   #4
Jeeper
 
Join Date: Mar 2014
Posts: 23
I was just at Adams today to pick up a joint rebuild kit. That place is great and they were very friendly and helpful.

I had a couple different things going on. My transfer case position switch was not working correctly, so the light was showing 4WD High while I was in 2WD. Since this Jeep is new to me, I didn't want to take any chances, so that is why I decided to stop and troubleshoot it. I wasn't sure if the transfer case linkage was off and if it wasn't shifting out of 4WD, or if it was just the light.

I reached under to see if I could feel the which position the transfer case was in, and I must have bumped the transmission shifter cable. Well when I got back in the Jeep, I noticed I couldn't put it in gear. The cheap plastic grommet that holds the shifter cable in place was just worn and fell apart. So I zip tied that back in place so I could drive home.

I fixed the light, and I think I am ready to hits the trails again after I rebuild the joint tomorrow.

Next on my list is a CB and a compressor.

Let know when you are doing another ride, so I can come along.
advjeeper is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 07:24 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC