Turn signal problems - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > Nevada Jeep Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-19-2013, 05:17 PM   #1
Newb
 
Join Date: May 2013
Location: North lake tahoe
Posts: 10
Turn signal problems

I have a 06jeep wrangler and the turn signals don't work. I replaced the fuse still nothing. The turn signals don't even light up on the dash. What should I do next? Thanks for the help

erick101avn7 is offline   Quote Quick Reply
Old 05-19-2013, 10:47 PM   #2
jokerchief462

WF Supporting Member
 
jokerchief462's Avatar
 
Join Date: Apr 2012
Location: North Las Vegas
Posts: 9,365
How about the emergency flasher does it work??? If so and all the lights work it is the flasher remove and replace or try swapping the flasher relay in the fuse panel. I have an 89 so I have no idea what you fuse panel works but it should be the same principle since nothing happens at all. Both the flasher relay for turn signals and the emergency flashers should be next to each other. Check it out see what you find.

__________________
89 2.5 TBI, 4" RC lift, 1" Booms, SYE, Adams Driveshafts front and rear, Ford 8.8 with 4:88s, BFG 33X12.50X15, and a ton of other stuff.

AF Jeep Club Tail Number 184
jokerchief462 is offline   Quote Quick Reply
Old 05-20-2013, 01:11 AM   #3
Newb
 
Join Date: May 2013
Location: North lake tahoe
Posts: 10
The emergency flashers do not work. I think I'm going to have to take it in. I will replace the bulbs tomorrow and if that doesn't work ill take it in. All my other lights work fine
erick101avn7 is offline   Quote Quick Reply
Old 05-20-2013, 09:37 AM   #4
Jeeper
 
Join Date: Jan 2013
Location: NLV, NV
Posts: 245
You might want to ask this in the TJ forum, you'll get a lot more views.
__________________
Sean
RepairMan is offline   Quote Quick Reply
Old 05-20-2013, 11:37 AM   #5
Jeeper
 
Xodius's Avatar
 
Join Date: Jan 2013
Location: Sin City
Posts: 221
What was the last thing you did when they worked?
If you have a circuit tester I would suggest trying that and run backwards until you find am issue.
__________________
2008 JKU Rescue Green OME HD lift, custom exhaust, sitting on some 35s on some MBs. Custom welded trunk as the factory one had to be a dare.
Forums/Clubs-
JKFreaks, JK-Forum(I KNOW I KNOW), Expedition Portal, L.O.S.T., KJ Country, Nevadashooters plus about a dozen others.
Xodius is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 02:02 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC