Evans Creek June 30th - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > Washington Jeep Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-01-2012, 09:06 PM   #1
Jeeper
 
Join Date: Oct 2011
Location: Olympia, WA
Posts: 2,840
Evans Creek June 30th

Six of us; Skawt, Mr. Fish, Rich, Tom, the Decandia's, and us. Headed out Saturday to check out Evans Creek.



We started in on the 311 trail and ran through the campground to 520. 311 was clear, and a good trail for the JK and JKUs in the group.





We hit 520 and it started out clear. Rich and I tried the first 'to the right' bad spot. Neither of us made it. I managed to polish that rock up black and shiny...













We both had to be strapped over it. From there, the switchbacks were tight enough that some of the JKUs had to make them in a 2 or 3 point turn.









nwbronco is offline   Quote Quick Reply
Old 07-01-2012, 09:16 PM   #2
Jeeper
 
Join Date: Oct 2011
Location: Olympia, WA
Posts: 2,840
Evans Creek June 30th part II

The forum is fighting me today for some reason. Got it take the first part. Now let's see how it behaves for the rest...

We managed to watch a tree for on Rich's rig as we went through another switchback.



And as you can see in the pic, it rained the entire time we were out there. Buckets at times.

We made it all the way up to about the 4100 foot level of 520, probably 1000 yards are so from the rock pile, and hit a heavy snowpack. Skawt got over it, Tom highcentered. We had to use Mr. Fish to help spin Skawt around on the snow. Then used him to pull Tom up and over. We got the other 4 rigs to back up about 100 yards to another turnaound spot. I managed to get soaked getting all this worked out. (Had a change of shirt and rain jacket in the rig fire after). I have no pics of this event. Not sure if one of the other guys did.

We headed back down 520 and hit 7930. Went and found the mudhole. (Anne had to see it). And Rich had to take a turn through it.





Bob K.
nwbronco is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 05:10 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC