Question on my DD... - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Discussion Forums > Off-Topic

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-08-2007, 11:15 AM   #1
Jeeper
 
Join Date: Jun 2007
Posts: 54
Question on my DD...

Got two questions for u guys... tryed going to a dodge neon forum but for some reason just doesnt get as good of a response as from a Jeep forum.. hehe..

I got a 2000 Dodge Neon ES as my DD lot better gas milage than the jeep Its started acting like its just not getting the amount of gas it needs... kindly spudders slightly when going up a steep hill or if i really mash the gas peddle down.. it has 120k miles on it.

The Fuel Pump has never been changed.. i went to local parts store to get a fuel filter try that before the hole pump. They tell me that for a 2000 neon u cannot buy just the filter.. its built into the fuel pump itself.. i was woundering if anyone knows if this is correct or if i can get just the filter. Also if anyone else could confirm that this could be my problem before i go buy a new pump. thanks in advance for any info.

__________________
SAVE THE WAVE!!
JeepWoL is offline   Quote Quick Reply
Old 08-08-2007, 11:40 AM   #2
Jeeper
 
debruins's Avatar
 
Join Date: Feb 2007
Location: Needham Ma, Rangeley ME in the summer
Posts: 5,578
Send a message via AIM to debruins
im not sure if this will work, bu ti would disconnect the fuel pump and with some compressed air blow back though it and see if junk comes out the intake, worth a try if your gonna end up replacing it!

debruins is offline   Quote Quick Reply
Old 08-08-2007, 12:55 PM   #3
Jeeper
 
Join Date: Jun 2007
Posts: 54
might try that first... but would u agree that it prob is eather the "built in filter" is stoped up or the pump is going bad that is the problem?
__________________
SAVE THE WAVE!!
JeepWoL is offline   Quote Quick Reply
Old 08-08-2007, 04:42 PM   #4
Jack Lives Here!!!

WF Supporting Member
 
1BLKJP's Avatar
 
Join Date: Apr 2005
Location: Phoenix, AZ
Posts: 7,764
I would imagine that filter/pump setup is the same on the TJ's as it is on the Neon's. It's all one piece inside the tank.

At 120k there are a few things I could think of that would be doing what you say. Bad/Dirty injectors and Fuel Pump would be first start for me. Have you checked the fuel pressure you are getting at the rail?
__________________
Thanks,
Jack Hickman

President - Arizona Off-Highway Vehicle Coalition
Vice-President - ASA4WDC
Arizona Rock Rats
1BLKJP is offline   Quote Quick Reply
Old 08-08-2007, 05:03 PM   #5
Pushy, Loudmouthed, and Ballsy
 
Dare2BSquare's Avatar
 
Join Date: Jul 2006
Location: Driving Around Arkansas In My Black XJ
Posts: 6,177
How long has it been doing this? Maybe you bought some cheap watery gas? Before you go to a lot of expense replacing parts dump a bottle of gas treatment / injector cleaner in the tank and see if it does anything for you.
__________________
99 XJ Sport
4.0l
AW4
NP231
d30/C8.25
3" Skyjacker lift
31 x 10.50 General Grabbers


http://i66.photobucket.com/albums/h2...are/TMLogo.gif Are all fishermen liars, or do only liars fish?
Dare2BSquare is offline   Quote Quick Reply
Old 08-08-2007, 05:05 PM   #6
Jack Lives Here!!!

WF Supporting Member
 
1BLKJP's Avatar
 
Join Date: Apr 2005
Location: Phoenix, AZ
Posts: 7,764
Quote:
Originally Posted by Dare2BSquare View Post
How long has it been doing this? Maybe you bought some cheap watery gas? Before you go to a lot of expense replacing parts dump a bottle of gas treatment / injector cleaner in the tank and see if it does anything for you.
Good point. Re-read my post and it looked like I ws telling him to go spend a ton of money. I was more referring to cleaning your injectors and checking your fuel pressure first.
__________________
Thanks,
Jack Hickman

President - Arizona Off-Highway Vehicle Coalition
Vice-President - ASA4WDC
Arizona Rock Rats
1BLKJP is offline   Quote Quick Reply
Old 08-08-2007, 05:54 PM   #7
Jeeper
 
Chad P's Avatar
 
Join Date: Jun 2007
Location: Westminster, Co
Posts: 380
I have never had a fuel pump kinda not work. They either work or don't. Check a few things. Air filter and MAS. check the air cleaner tube as well if you got a hole in it it wont run good.
__________________
2003 Wrangler TJ
All stock for now!
Chad P is offline   Quote Quick Reply
Old 08-08-2007, 07:42 PM   #8
Jeeper
 
Join Date: Jun 2007
Posts: 54
yeah problems began about a week ago when i got some gas from a dif than normal place... iv tryed puttin in the stuff to take out water in the gas.. bought the a bottle of the injector cleaner today to put in it and see if that helps.. but ill check the air filter tomorrow also and see if theres anything wrong there... hopefully ill figure it out and it not end up costing me a crapload before i do...
__________________
SAVE THE WAVE!!
JeepWoL is offline   Quote Quick Reply
Old 08-09-2007, 10:27 PM   #9
Jeeper
 
Join Date: Jun 2007
Posts: 54
amazingly a bottle of STP fuel injector cleaner fixed the prob...
__________________
SAVE THE WAVE!!
JeepWoL is offline   Quote Quick Reply
Old 08-09-2007, 10:48 PM   #10
Pushy, Loudmouthed, and Ballsy
 
Dare2BSquare's Avatar
 
Join Date: Jul 2006
Location: Driving Around Arkansas In My Black XJ
Posts: 6,177
You can send me the money you were gonna spend on a fuel pump/filter/labor. I saved you some cash!!!

__________________
99 XJ Sport
4.0l
AW4
NP231
d30/C8.25
3" Skyjacker lift
31 x 10.50 General Grabbers


http://i66.photobucket.com/albums/h2...are/TMLogo.gif Are all fishermen liars, or do only liars fish?
Dare2BSquare is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
quick axle question Sb5551 TJ Tech Forum 3 10-03-2008 08:38 PM
front fender question jeeps&comics YJ General Discussion Forum 10 06-23-2008 04:29 PM
Trans Mount Question MOz TJ Tech Forum 8 06-10-2008 03:14 PM
Spring Over Question WranglerHawg YJ Tech Forum 1 09-17-2007 10:06 AM
Carb question and EGR question trulefty YJ Tech Forum 0 12-12-2006 04:55 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 03:06 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC