has anyone in the NW had the dreaded tick yet? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > Oregon Jeep Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-02-2012, 07:21 PM   #1
Jeeper
 
Join Date: Jun 2012
Location: Camas wa
Posts: 152
has anyone in the NW had the dreaded tick yet?

I am sure we all seen the threads with the new JK's and the dreaded tick/head replacement. I was just curious if anyone here locally had to deal with it yet, and if they did how did the dealer treat them?

I have a 2012 with 5K on it and the only problem I have is prying the keys out of my wife’s hand




Randy-S is offline   Quote Quick Reply
Old 10-02-2012, 09:29 PM   #2
Jeeper

WF Supporting Member
 
scoobyjeep's Avatar
 
Join Date: Jul 2011
Location: wilsonville
Posts: 604
Images: 4
Quote:
Originally Posted by Randy-S View Post
I am sure we all seen the threads with the new JK's and the dreaded tick/head replacement. I was just curious if anyone here locally had to deal with it yet, and if they did how did the dealer treat them?

I have a 2012 with 5K on it and the only problem I have is prying the keys out of my wife’s hand



i don't know if this appys to jeeps or not but the 3.6L in the grand caravans and town and country's have a TSB about a cylinder 3 misfire requireing head replacemnt

__________________
"People sleep peacefully in their beds at night only because rough men stand ready to do violence on their behalf."
-- George Orwell
"those who can do, those who can't try harder"
scoobyjeep is offline   Quote Quick Reply
Old 10-03-2012, 09:42 AM   #3
Jeeper
 
Join Date: Jun 2012
Location: Camas wa
Posts: 152
You would think it was more widespread then just the wranglers
I was interested in seeing how are local dealers were dealing with it.
Randy-S is offline   Quote Quick Reply
Old 10-03-2012, 09:48 AM   #4
Jeeper

WF Supporting Member
 
scoobyjeep's Avatar
 
Join Date: Jul 2011
Location: wilsonville
Posts: 604
Images: 4
Quote:
Originally Posted by Randy-S View Post
You would think it was more widespread then just the wranglers
I was interested in seeing how are local dealers were dealing with it.
if its under warranty they have to fix the problem, i haven't dealt with any of the dealers. but jeep in Beaverton does decent work from what i have heard
__________________
"People sleep peacefully in their beds at night only because rough men stand ready to do violence on their behalf."
-- George Orwell
"those who can do, those who can't try harder"
scoobyjeep is offline   Quote Quick Reply
Old 10-03-2012, 10:22 AM   #5
Jeeper
 
Join Date: Jun 2012
Location: Camas wa
Posts: 152
I have not had to deal with any of the local dealers I purchased my jeep in Seattle
I live closest to dick Hannah but I can't say I am a fan of them
Randy-S is offline   Quote Quick Reply
Old 10-03-2012, 01:23 PM   #6
Jeeper

WF Supporting Member
 
rvkillian's Avatar
 
Join Date: Sep 2011
Location: Portland, Oregon
Posts: 109
I bought my 2012 in May. 6400 miles with no tick yet.
rvkillian is offline   Quote Quick Reply
Old 10-04-2012, 01:21 PM   #7
offroadvegan

WF Supporting Member
 
scottmphoto's Avatar
 
Join Date: Mar 2011
Location: Rhododendron, OR
Posts: 831
2012 Rubi here, 3k miles. Nothing yet.
__________________
Check out my blog - Offroadvegan!

2013 Wrangler Rubicon Unlimited Billet "Frank the Tank"

“The Jeep is America’s only real sports car.” - E. Ferrari
scottmphoto is offline   Quote Quick Reply
Old 10-09-2012, 09:05 AM   #8
Jeeper
 
Join Date: Jun 2012
Location: Camas wa
Posts: 152
Nice to hear the only problem I have with my jeep is trying to decide what front bumper I want to install
Randy-S is offline   Quote Quick Reply
Old 10-10-2012, 08:33 PM   #9
Supporting Member

WF Supporting Member
 
dmingu001's Avatar
 
Join Date: Apr 2012
Posts: 233
2012 JK 4K no tick. Build date 2\12 I bought my from NW jeep in Beaverton. Very happy with the folks I dealt with when my gas tank cracked
dmingu001 is offline   Quote Quick Reply
Old 10-12-2012, 04:53 PM   #10
Jeeper
 
Join Date: Jun 2012
Location: Camas wa
Posts: 152
So they treated well that's good to know my jeep new also and I can take it to any dealership I want if I do have a service issues
Randy-S is offline   Quote Quick Reply
Old 10-20-2012, 10:51 PM   #11
Jeeper
 
Blastek's Avatar
 
Join Date: Mar 2012
Location: Portland, OR
Posts: 2,031
i had my head replaced just over a month ago. runs great now. i got some really bad service in hillsboro, so i took it to T&C in wilsonville and they did a great job with the head.

edit, yes, i used the words bad, service, great, job, and head in the same sentence.
__________________
2012 Deep Cherry Red JKU Sport S - Tickastar, 6 speed, 3.73, Dual Tops
Blastek is offline   Quote Quick Reply
Old 10-22-2012, 09:14 AM   #12
Jeeper
 
Join Date: Jun 2012
Location: Camas wa
Posts: 152
Quote:
Originally Posted by Blastek
i had my head replaced just over a month ago. runs great now. i got some really bad service in hillsboro, so i took it to T&C in wilsonville and they did a great job with the head.

edit, yes, i used the words bad, service, great, job, and head in the same sentence.
Can you give some more feedback about your experience? Age and miles on your jeep
How many trips to the dealer did it take.
How long did the repair take did they provide a loaner?
Randy-S is offline   Quote Quick Reply
Old 10-22-2012, 03:30 PM   #13
Jeeper
 
Blastek's Avatar
 
Join Date: Mar 2012
Location: Portland, OR
Posts: 2,031
Quote:
Originally Posted by Randy-S View Post
Can you give some more feedback about your experience? Age and miles on your jeep
How many trips to the dealer did it take.
How long did the repair take did they provide a loaner?
my tick started at about 1k miles. late april build. I had it in at hillsboro and they said it was normal. brought it in at about 2k miles and this time they were willing to pull the valve cover and check. but, after they screwed up my oil change twice, I thought it best not to let them handle anything major, including pulling a valve cover.

wilsonville was much different. i had about 8k miles on it at this point, but still no CEL. I dropped it off at 8am, got a call at noon from enterprise asking me when i wanted to pick up my loaner (durango) before i even got in touch with the dealer.

they pulled the valve cover and had found found loose lifters. I had the jeep back 3 days later (due to waiting for parts and i also had the emergency brake replaced). I think the actual head repair took 1 day or less. so for T&C in wilsonville, it was 1 trip to drop it off, 1 to pick it up.
__________________
2012 Deep Cherry Red JKU Sport S - Tickastar, 6 speed, 3.73, Dual Tops
Blastek is offline   Quote Quick Reply
Old 10-22-2012, 10:59 PM   #14
Jeeper
 
Join Date: Oct 2012
Posts: 38
edit: lol, oops, wrong thread
lovecomplex is offline   Quote Quick Reply
Old 10-23-2012, 10:12 AM   #15
Jeeper
 
Join Date: Jun 2012
Location: Camas wa
Posts: 152
Quote:
Originally Posted by Blastek

my tick started at about 1k miles. late april build. I had it in at hillsboro and they said it was normal. brought it in at about 2k miles and this time they were willing to pull the valve cover and check. but, after they screwed up my oil change twice, I thought it best not to let them handle anything major, including pulling a valve cover.

wilsonville was much different. i had about 8k miles on it at this point, but still no CEL. I dropped it off at 8am, got a call at noon from enterprise asking me when i wanted to pick up my loaner (durango) before i even got in touch with the dealer.

they pulled the valve cover and had found found loose lifters. I had the jeep back 3 days later (due to waiting for parts and i also had the emergency brake replaced). I think the actual head repair took 1 day or less. so for T&C in wilsonville, it was 1 trip to drop it off, 1 to pick it up.
Wow that sounds like amazing service! I will keep that in mind if I ever need warranty work
Thanks for sharing

Randy-S is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 05:41 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC