Stumbling Idle - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > Kentucky Jeep Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on
Old 06-01-2014, 12:08 PM   #1
lrss53's Avatar
Join Date: Jun 2014
Location: Louisville,KY
Posts: 1
lrss53 is on a distinguished road
Stumbling Idle

Greetings to all from Louisville. I am a new member and am the proud owner of a 1999 XJ 4.0 It has 103K miles with Spicer Track Lock in rear Dana 44. I have owned the Jeep since 40K. I am experiencing a bad stumbling idle at start up. I have new plug wires/new Autolite plugs/new cam shaft position sensor/new IAC/new TPS and it still stumbles. I haven't checked the fuel pressure yet but have tried turning the key on repetitively to prime the pump and it still doesn't idle well. It acts like its hitting on 4 cylinders until it warms up. No codes on the computer. Please Help with suggestions Thanks
lrss53 is offline   Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 07:35 AM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC. is not in any way associated with the Chrysler Motors LLC
« Back

Enter your email address:

Delivered by FeedBurner