Starting woes - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > North Carolina Jeep Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-23-2012, 10:05 PM   #1
Jeeper
 
Join Date: Jun 2012
Location: Willard, NC
Posts: 36
Starting woes

Hi all. New here and having an issue. I have a new-to-me 1987 Wrangler, 4.2, auto 3-speed on the tree, 4x4 with a 1989 engine. In the mornings, when I turn the key, I get power to all the gauges but the starter doesn't kick in right away. Takes 4-5 seconds. Switch cylinder is brand new due to it being kinda hard to turn... and 25 years old. Battery is strong. Starter is new, as is lots of engine parts (alt, fuel pump, distributor, etc). What could be causing this? Also have a grinding-ish sound that may be the power steering pump. Pulleys kinda funky. Replacing it now. BUT, it only happens first thing in the morning.

Eddiekimberly is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 07:56 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC