Very difficult start...what is my issue? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > Virginia Jeep Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-01-2013, 02:09 PM   #1
Newb
 
Join Date: Sep 2013
Posts: 1
Very difficult start...what is my issue?

When I initially turn the key it seems like I have a dead battery. If I hold the key it slowly starts to crank and then will start if I feather the gas pedal. When I come to a stop or let it go down to idle it will stop running, again, unless I continually press the gas pedal. After a while it seems to get better and will idle. I changed all 4 oxygen sensors (Cali emissions) and put injector cleaner in my last refill. I am worried I am doing more damage but don't know where to begin. No fault codes show on my reader. Has anyone else experiences this?

cyeag27 is offline   Quote Quick Reply
Old 09-01-2013, 05:57 PM   #2
Newb
 
Yeti6669's Avatar
 
Join Date: Jul 2013
Location: Northern Virginia
Posts: 12
Quote:
Originally Posted by cyeag27 View Post
When I initially turn the key it seems like I have a dead battery. If I hold the key it slowly starts to crank and then will start if I feather the gas pedal. When I come to a stop or let it go down to idle it will stop running, again, unless I continually press the gas pedal. After a while it seems to get better and will idle. I changed all 4 oxygen sensors (Cali emissions) and put injector cleaner in my last refill. I am worried I am doing more damage but don't know where to begin. No fault codes show on my reader. Has anyone else experiences this?
What octane/brand gas are you using. If I buy gas from the PX I have a similar problem but the TJ loves Shell or Liberty fuel. I also went back to 5w-30 instead of 10w-30 and it seems to be doing better with a thinner oil.

When was your last tune up/cap-rotor/ignition coil replacement?
Yeti6669 is offline   Quote Quick Reply
Reply

Tags
hard start , hold key , start issue

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 07:04 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC