Tranny troubles - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > Michigan Jeep Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-11-2012, 06:38 PM   #1
Newb
 
Join Date: Sep 2012
Posts: 4
Tranny troubles

My 03 stopped shifting today. With the jeep running and not engaging clutch there is no grinding. With jeep off and in gear I can still roll the jeep. Clutch or tranny what should I check next?

03huskie is offline   Quote
Old 09-11-2012, 10:18 PM   #2
Grampie

WF Supporting Member
 
stans1stjeep's Avatar
 
Join Date: Dec 2011
Location: Rochester, Mi
Posts: 783
Clutch.

stans1stjeep is offline   Quote
Old 09-12-2012, 06:59 PM   #3
Newb
 
Join Date: Sep 2012
Posts: 4
Thanks I have checked fluid level it's fine and don't see any leaks. Any suggestions on what part of clutch to check and how
03huskie is offline   Quote
Old 09-12-2012, 08:10 PM   #4
Grampie

WF Supporting Member
 
stans1stjeep's Avatar
 
Join Date: Dec 2011
Location: Rochester, Mi
Posts: 783
The pads on either the pressure plate or clutch plate or both, my have gone away.
stans1stjeep is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 09:57 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC