Running like Crap Again! - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > Pennsylvania Jeep Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-13-2012, 11:06 AM   #1
Newb
 
Join Date: May 2012
Location: Mount Carmel, PA
Posts: 9
Running like Crap Again!

Well, I had a short stay with my jeep running like it had a extra 100hp. It's back to running like crap again. I think it's the catalytic converter, so this weekend I'm do away with it and see if it solves the problem. I was going up a mountain this past weekend and had it to the floor in 2rd gear and the rmps didn't get over 3000?? Plus I'm hearing some rattling around n the converter.

Chico1970 is offline   Quote
Old 06-17-2012, 07:14 PM   #2
Jeeper
 
Bob 97 TJ's Avatar
 
Join Date: Jan 2012
Posts: 62
That is the same thing with mine just haven't got around to changing it.
Bob 97 TJ is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 05:59 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC