Jeep Wrangler Forum - View Profile: JeepInUse
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > Members List

Join Wrangler Forum Today


JeepInUse JeepInUse is offline

Jeeper

Profile Comments

Showing Profile Comments 1 to 2 of 2
  1. i82much
    02-15-2012 08:57 PM
    i82much
    Ok thanks. Yeah, I will definitely keep an eye on it. No check engine light yet so I am not super-worried. From the comments it seems like it has to get fairly loud before the dealers will do anything about it.
  2. i82much
    02-15-2012 12:04 PM
    i82much
    Hi,

    I was just wondering if you could answer a quick question about your cylinder head problem. My '12 was built 9/2/2011, has about 3k miles on it. This morning I noticed a fairly loud ticking noise right at startup on the driver's side but it literally went away after 2 seconds or so. Is that sort of how your problem started?

    Thanks,
    Steve

About Me

  • About JeepInUse
    Gender
    Male
    WF Local
    North Carolina
  • Signature
    2012 Unlimited Sahara
    Cosmos Blue
    2012 Overland Summit
    Mineral Grey
    1970 SS Camaro L34 (Real Big Block)

Statistics

Total Posts
Profile Comments
General Information
  • Last Activity: 04-25-2012 06:15 PM
  • Join Date: 12-31-2011
  • Referrals: 0

Jeep Profile


    Unlimited Sahara

All times are GMT -5. The time now is 03:24 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC