Jeep Wrangler Forum - View Profile: jloesche
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > Members List

Join Wrangler Forum Today


jloesche jloesche is offline

Newb

Profile Comments

Showing Profile Comments 1 to 1 of 1
  1. Jad
    03-24-2013 07:05 AM
    Jad
    Hello, I have exactly the same problem that you had. Mine was P0300 random misfire, engine was vibrating and shaking and I lose power above 3000rpm. My name is Jad from the united arab emirates, Dubai. I have a jeep wrangler sahara tj 2006 model done 130000km. My car is programed with Diablo trinity, header, filter, catback, edge throttle body with the module, V8 5.7 2 speed grand cherokee electrical fan, 4 blocks aluminim radiator and a themostat that opens on 70 celius. The certified dealer have done every single test that u could imagine and said that is nothing is wrong with the car. The random misfire might be from the map sensors of the throttle body or an Internal problem in the PCM. And you are the only person online who said that you have changed the PCM and your problem was fixed. Could you please msg me back or email me on jadshalak@gmail.com and explain to me how you fixed your car and if it is back to normal. Thank you very much

About Me

  • About jloesche
    Gender
    Male
    Location
    Spring, TX
    Occupation
    Power Plant Operations Manager
    WF Local
    Texas
    Vehicle 1
    2006 Jeep Wrangler Unlimited

Statistics

Total Posts
Profile Comments
General Information
  • Last Activity: 02-18-2013 09:59 AM
  • Join Date: 06-16-2011
  • Referrals: 0

Contact Info

Instant Messaging
Send an Instant Message to jloesche Using...
This Page
http://www.wranglerforum.com/members/jloesche-56770.html

Jeep Profile


    Chief

All times are GMT -5. The time now is 10:20 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC