Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Transmission Question?

Join Wrangler Forum Today


Thread: Transmission Question? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-15-2011 11:29 AM
Crso8541 New valve cover going on today, then having the rear main replaced. hopefully will put a dent in the leak dpeartment for a while
02-14-2011 10:58 PM
Jeepin91YJ Looks like valve cover. Pull off clean real good and get old gasket/ RTV off and and put red RTV on and clean engine and watch for leak. If it down there near inspection plate might be rear main.
02-13-2011 10:33 PM
Crso8541 Yeah I drove it kinda hard today, lot of hills, but i didn't push it. Guess i have something to do when i get home from work tomorrow.
02-13-2011 10:28 PM
AzTJ Yup - gets nasty quick. Just replaced the valve gasket on my mothers XJ... FILTHY.
02-13-2011 10:25 PM
Crso8541 Its black. I think the camera was playing tricks. I just didn't think the valve cover could allow that much oil. But i guess so. Here is the side of the engine and you can see where all the oil is coming from.



02-13-2011 10:24 PM
Crso8541 ok I just can't tell, i got to take somewhere and get all the leaks that just sprouted fixed. I don't know what all is leaking so i'm going to start with the top and work down. I just didn't know looking under there if that was good or not. I think most of the oil is coming from the pan seal and valve cover gasket.
02-13-2011 10:15 PM
89JEEPYJ is it black oil or red??
02-13-2011 10:12 PM
AzTJ The oil leak is quite possibly the valve cover gasket or the rear main seal. Both fairly common for the 4.0L.
02-13-2011 10:11 PM
89JEEPYJ well its on the houseing and from the buttom to 5 inchs+ up is the plate. should be really thin and flimbsy
02-13-2011 10:10 PM
89JEEPYJ its a silver plate on the butom part off the trans
02-13-2011 10:09 PM
Crso8541 Is the inspection cover the silver plate or the black plate?
02-13-2011 10:07 PM
Crso8541 getting down there and looking i think its between the engine, is there something i shouldn't be able to see?
02-13-2011 10:06 PM
89JEEPYJ is that gap between the motor and trans. or between the trans and the inspection plate?
02-13-2011 10:04 PM
Crso8541 Also trying to figure out where all this oil came from. I think my valve cover gasket is bad but i figured that would be kind of a slow gradual thing.
02-13-2011 09:47 PM
Crso8541
Transmission Question?

Is the gap there right?


Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:04 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC