Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Wiper problem - 2005 Wrangler Unlimited

Join Wrangler Forum Today


Thread: Wiper problem - 2005 Wrangler Unlimited Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-28-2011 11:09 AM
Danashold
Wiper problem - 2005 Wrangler Unlimited

I have a 2005 Wrangler Unlimited. The other day the wipers decided not to work. This was coincidentally a day after I replaced the wiper blades, which functioned properly after replacing them. Prior to replacing the blades I had just been in a heavy snow storm the week before.

I've checked some basics; fuses and wiper motor, all are good. I did find I am not getting power to the motor, which brings me to the end of my ability to troubleshoot.

Although there may not be a connection I noticed the cigar lighter is not working now either (fuse is also good). I use it everyday to charge my cell, so it seems like more than a coincidence that it happened at the same, or very nearly the same time.

Any help would be appreciated. I've scoured the forums looking for similar problems but nothing has helped yet. The Jeep dealer, without looking at it, guesses it is the control module ($200+) or the switch ($100+).

Thanks in advance!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:41 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC