Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Weird Warn winch problem, still...

Join Wrangler Forum Today


Thread: Weird Warn winch problem, still... Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-03-2011 09:38 PM
Jerry Bransford That'd be one expensive steak but anytime.
03-03-2011 09:33 PM
Phil05LJ
Quote:
Originally Posted by Jerry Bransford
How sure are you that the ground wire you have connected to the grill is providing a good solid electrical ground connection? Try temporarily running a jumper cable or wire from the battery's negative post and hold it against the winch's ground wire at the grill and see if that added ground connection gets the winch going.
I'm gonna hop on a plane to the west coast and buy you a steak dinner Jerry! It worked!!! Oh what a relief! I'll make sure that ground wire is grounded to the frame this weekend, too dark and cold tonight. I'm still amazed that what I thought was a good ground wasn't, just another life lesson learned. Thank you very much for the advice, I'll be able to sleep much better now.
03-03-2011 08:46 PM
Jerry Bransford How sure are you that the ground wire you have connected to the grill is providing a good solid electrical ground connection? Try temporarily running a jumper cable or wire from the battery's negative post and hold it against the winch's ground wire at the grill and see if that added ground connection gets the winch going.
03-03-2011 08:34 PM
Phil05LJ
Weird Warn winch problem, still...

So I posted last month about a dead winch. I've determined that the motor and solenoids are fine, the remote was bad. Warn sent me a new remote under warranty, nice of them, the new remote worked so I spooled out the line 10 feet and back in, hooked the hook to a D-ring and gave it a few bumps to tension the line and then nothing. The new remote does not work now. All connections are clean and tight, the small gauge ground wire is bolted to the grille and tight, the tow hook that the D-ring hooks to is Rhino lined and the hook touches the winch mounting plate, that seems like when both of the remotes died. What the heck can be wrong? I'm desperate at this point, I doubt Warn will send me another remote. Thanks very much for any help!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:09 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC