Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > speedo gears going nuts

Join Wrangler Forum Today


Thread: speedo gears going nuts Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-09-2011 07:35 PM
jeepskala
Quote:
Originally Posted by jeepskala View Post
ok i did all the obove. i got the blue jeep done and works A OkAY now i did the same thing on the green one. still nothing. the engine light is on the speed gear. and i did everything right and still no luck?? does anyone know the eletrical end of this?

well it looks like its the wrong sensor also... someone before me deff changed the sensors and sliced the wires.

i put the gear in the sensor, and put a drill to the gear spun it fast, and the speedomiter did not move. so i found out the sensor is the same on as on a ZJ and my buddy is scrapping his zj so ill take his sensor and wire pig tail and try that.. any other sugestions?
03-09-2011 07:24 PM
Jerry Bransford When that happens, it is usually nothing more than the speedometer gear housing just needs to be rotated a tad more so the speedometer gear can engage the pinion gear underneath.
03-09-2011 07:20 PM
jeepskala ok i did all the obove. i got the blue jeep done and works A OkAY now i did the same thing on the green one. still nothing. the engine light is on the speed gear. and i did everything right and still no luck?? does anyone know the eletrical end of this?
03-09-2011 07:22 AM
h2obill some quick info here Changing Your Jeep Speedometer Gear

03-09-2011 06:52 AM
jeepskala ok that helps... now, also if i change the speed gear i have to change the positition of the sensor
03-09-2011 02:38 AM
Wesboy Each speedo gear housing can be re-installed 4 different ways. If it isn't reinstalled the right way, the speedo will not work.
There are numbers on the plastic housing relating to number of speedo gear teeth, the relevant numbers are supposed to line up with a notch on the transfer case.

Well, I couldn't find what I had to line it up with so I re-installed the housing in each of 4positions until the speedo worked.
03-08-2011 10:12 PM
jeepskala if it helps the green jeep that now has 4.10 gears also has a SYE
03-08-2011 09:32 PM
jeepskala
speedo gears going nuts

ok i have two jeeps... a blue 97, with 410 gears, and a green 97 with 307 gears.

i swapped the axles over, so now the blue one have 307s and the green has 410s.

i went to go swap the speedo gear. what do you know. the plugs are different... so then i look on here find out that the gears remove out of the sensor.

finaly getting the sensor and gear out of the green truck(the gear ment for 307) realise the gear is not staying in the sensor... either way i take it out. and go to put it in the blue jeep that now has the 307s. gear clicks in bolt it on. speedo does not work...

go to the the gear (meant for 410s) in the green jeep. i cannot get the sensor to go in strieght...

WTF>>>>>

so i said F%$k it and put the speedo gears back into the trucks they came from even tho they are not set up for the new ratios..

the blue jeep with 307s that has a speedo gear for 410s work just not accurate as before. BUT!! the green jeep that now has the 410 gears but has the speed gear for a 307 does not work. it is in strieght, and all the way, and now engine light is on for speed gear..

ARG:banghe ad:

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:34 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC