Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Fuse problem tail lights

Join Wrangler Forum Today


Thread: Fuse problem tail lights Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-17-2011 05:49 AM
Undead-89 Definitely a short (unless you have the wrong size fuse in there). i would check the bulb sockets and make sure nothing is in them like metal pieces, shavings or water. I would also make sure they aren't loose. and make sure whatever insulates the socket from the contacts is intact.

Check the switch for the headlights, make sure it isn't broken, cracked or wet inside.

If it happens when you turn on the marker lights but not the headlights you will reduce the number of wires you need to check. And wires are the next thing you need to check. The main places are anywhere they connect to a fixture or connector body and anywhere they pass through a body panel.

You are looking for loose connections, frayed connections and places where the insulation is worn from rubbing against any metal.
04-16-2011 11:02 PM
SUBZEROCOOL
Fuse problem tail lights

Rear driving lights and dash lights keep blowing fuses. It started when I was trying to replace a rear light bulb and broke the bulb and burnt a fuse. I replaced the bulb and fuse and all ran well for weeks, now my Jeep is blowing the fuse as soon as I turn on the lights. I'm thinkig short somewhere

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:10 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC